<!DOCTYPE html>
<html lang="en-GB" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
	<title>A look back at 2018 with Star Boxing -  - Boxing News - Ring News24</title>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="A look back at 2018 with Star Boxing" />
<meta name="og:image" content="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="2018 was certainly a memorable year for Joe DeGuardia's Star Boxing.

Leading a year of many highlights was the highly anticipated return of former WBO Super Lightweight Champion Chris Algieri. On N" />
<meta name="og:url" content="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" />
	
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="/favicon.ico" />
	<link rel="pingback" href="https://www.ringnews24.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1250px; }
		#gk-mainbody-columns > aside { width: 22%;}
	#gk-mainbody-columns > section { width: 78%; }
	#gk-mainbody-columns { background-position: 78% 0!important; }
		
		#gk-inset { width: 27%;}
	#gk-content-wrap { width: 73%; }
	#gk-mainbody-columns > section { background-position: 73% 0!important; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"https://www.ringnews24.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"https://www.ringnews24.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		
<!-- This site is optimized with the Yoast SEO plugin v9.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="2018 was certainly a memorable year for Joe DeGuardia&#039;s Star Boxing. Leading a year of many highlights was the highly anticipated return of former WBO"/>
<link rel="canonical" href="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A look back at 2018 with Star Boxing - Ring News 24" />
<meta property="og:description" content="2018 was certainly a memorable year for Joe DeGuardia&#039;s Star Boxing. Leading a year of many highlights was the highly anticipated return of former WBO" />
<meta property="og:url" content="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" />
<meta property="og:site_name" content="Ring News 24" />
<meta property="article:publisher" content="https://www.facebook.com/ringnews24/" />
<meta property="article:section" content="Boxing News" />
<meta property="article:published_time" content="2019-01-11T14:25:29+00:00" />
<meta property="og:image" content="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg" />
<meta property="og:image:secure_url" content="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg" />
<meta property="og:image:width" content="497" />
<meta property="og:image:height" content="215" />
<meta property="og:image:alt" content="Star Boxing" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="2018 was certainly a memorable year for Joe DeGuardia&#039;s Star Boxing. Leading a year of many highlights was the highly anticipated return of former WBO" />
<meta name="twitter:title" content="A look back at 2018 with Star Boxing - Ring News 24" />
<meta name="twitter:site" content="@ringnews24" />
<meta name="twitter:image" content="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg" />
<meta name="twitter:creator" content="@ringnews24" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ring News 24 &raquo; Feed" href="https://www.ringnews24.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringnews24.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='gavern-normalize-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/normalize.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/template.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/stuff.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.extensions.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/extensions.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.typography.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.elements.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.template.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/desktop.small.css?ver=5.0.3' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.css?ver=5.0.3' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.small.css?ver=5.0.3' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/mobile.css?ver=5.0.3' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/style1.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.ringnews24.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dcwss-css'  href='https://www.ringnews24.com/wp-content/plugins/wordpress-social-stream/css/dcwss.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ringnews24.com/wp-content/themes/News/fonts/fontawesome/font-awesome.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.ringnews24.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.0.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/ssb_bar_script.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/jquery.cookie.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/wordpress-social-stream/js/jquery.social.stream.wall.1.6.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/wordpress-social-stream/js/jquery.social.stream.1.5.13.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/slideshow.js?ver=5.0.3'></script>
<link rel='https://api.w.org/' href='https://www.ringnews24.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringnews24.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringnews24.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.ringnews24.com/?p=78163' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2019%2F01%2F11%2Fa-look-back-at-2018-with-star-boxing%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2019%2F01%2F11%2Fa-look-back-at-2018-with-star-boxing%2F&#038;format=xml" />
<!-- Custom Styling Social Stream -->
<style type="text/css">
.stream li.dcsns-twitter .section-intro,.filter .f-twitter a:hover, .wall-outer .dcsns-toolbar .filter .f-twitter a.iso-active{background-color:#4ec2dc!important;}.stream li.dcsns-facebook .section-intro,.filter .f-facebook a:hover, .wall-outer .dcsns-toolbar .filter .f-facebook a.iso-active{background-color:#3b5998!important;}.stream li.dcsns-google .section-intro,.filter .f-google a:hover, .wall-outer .dcsns-toolbar .filter .f-google a.iso-active{background-color:#2d2d2d!important;}.stream li.dcsns-rss .section-intro,.filter .f-rss a:hover, .wall-outer .dcsns-toolbar .filter .f-rss a.iso-active{background-color:#FF9800!important;}.stream li.dcsns-flickr .section-intro,.filter .f-flickr a:hover, .wall-outer .dcsns-toolbar .filter .f-flickr a.iso-active{background-color:#f90784!important;}.stream li.dcsns-delicious .section-intro,.filter .f-delicious a:hover, .wall-outer .dcsns-toolbar .filter .f-delicious a.iso-active{background-color:#3271CB!important;}.stream li.dcsns-youtube .section-intro,.filter .f-youtube a:hover, .wall-outer .dcsns-toolbar .filter .f-youtube a.iso-active{background-color:#DF1F1C!important;}.stream li.dcsns-pinterest .section-intro,.filter .f-pinterest a:hover, .wall-outer .dcsns-toolbar .filter .f-pinterest a.iso-active{background-color:#ff0000!important;}.stream li.dcsns-lastfm .section-intro,.filter .f-lastfm a:hover, .wall-outer .dcsns-toolbar .filter .f-lastfm a.iso-active{background-color:#C90E12!important;}.stream li.dcsns-dribbble .section-intro,.filter .f-dribbble a:hover, .wall-outer .dcsns-toolbar .filter .f-dribbble a.iso-active{background-color:#F175A8!important;}.stream li.dcsns-vimeo .section-intro,.filter .f-vimeo a:hover, .wall-outer .dcsns-toolbar .filter .f-vimeo a.iso-active{background-color:#4EBAFF!important;}.stream li.dcsns-stumbleupon .section-intro,.filter .f-stumbleupon a:hover, .wall-outer .dcsns-toolbar .filter .f-stumbleupon a.iso-active{background-color:#EB4924!important;}.stream li.dcsns-deviantart .section-intro,.filter .f-deviantart a:hover, .wall-outer .dcsns-toolbar .filter .f-deviantart a.iso-active{background-color:#607365!important;}.stream li.dcsns-tumblr .section-intro,.filter .f-tumblr a:hover, .wall-outer .dcsns-toolbar .filter .f-tumblr a.iso-active{background-color:#385774!important;}.stream li.dcsns-instagram .section-intro,.filter .f-instagram a:hover, .wall-outer .dcsns-toolbar .filter .f-instagram a.iso-active{background-color:#413A33!important;}.wall-outer .dcsns-toolbar .filter li a {background:#777;}</style>
<link href="https://www.ringnews24.com/?opensearch_description=1" title="Ring News 24" rel="search" type="application/opensearchdescription+xml" /><link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-270x270.png" />
	
	<link href="https://fonts.googleapis.com/css?family=Hammersmith+One" rel="stylesheet" type="text/css" /><style type="text/css">
body,
h1, h2, h3, h4, h5, h6,
#main-menu > li li,
.bigtitle h3.header,
.box.badge-new .box-title::after,
.box.badge-popular .box-title::after,
.box.badge-top .box-title::after,
.box.bigtitle .box-title { font-family: Arial, Helvetica, sans-serif; }

#gk-logo.text,
#main-menu > li,
#top-menu,
#gk-user-area,
.box .box-title,
.gk-tabs-nav,
.nsphover .gk-nsp-category { font-family: 'Hammersmith One'; }

</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'https://www.ringnews24.com';
           $GK_TMPL_URL = 'https://www.ringnews24.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "width_height_opacity";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
	
		
		<link rel="stylesheet" type="text/css" href="https://www.ringnews24.com/wp-content/themes/News/css/override.css">

	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-5502369698975283",
	          enable_page_level_ads: true
	     });
	</script>
</head>
<body class="post-template-default single single-post postid-78163 single-format-standard" data-mobile="true" data-tablet-width="1030">
	<header id="gk-page-top">
		<div class="gk-page topbar">
						<h1>
				<a href="https://www.ringnews24.com" class="imageLogo"><img src="https://www.ringnews24.com/wp-content/uploads/2015/07/155x100.png" alt="" width="500" height="134" /></a>
			</h1>
						<div class="topad">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Homepage - Top advert 320x100 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:320px;height:100px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="2256322169"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
		</div>
		<div class="gk-page menubar">
			
			
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-42794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42794"><a href="http://www.ringnews24.com/">RN24</a></li>
<li id="menu-item-42984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42984"><a href="https://www.ringnews24.com/boxing-streaming/">Live Streaming</a></li>
<li id="menu-item-42941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42941"><a href="https://www.ringnews24.com/boxing-social-media/">Social Media</a></li>
<li id="menu-item-72225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72225"><a href="https://www.ringnews24.com/category/cheapest-boxing-tickets/">Boxing Tickets</a></li>
<li id="menu-item-65301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65301"><a href="https://www.ringnews24.com/category/supplements-for-boxing-mma/">Supplements</a></li>
<li id="menu-item-42805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42805"><a rel="nofollow" href="http://www.koboxingforum.com">Boxing Forum</a></li>
<li id="menu-item-64797" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-64797"><a title="Our Writers" href="https://www.ringnews24.com/2013/05/25/writers-articles-2/">Our Writers</a></li>
</ul>				<div id="main-menu-mobile" class="menu-{menu slug}-container"><select onchange="window.location.href=this.value;"><option value="#">Select a page</option><option value="http://www.ringnews24.com/"> RN24</option><option value="https://www.ringnews24.com/boxing-streaming/"> Live Streaming</option><option value="https://www.ringnews24.com/boxing-social-media/"> Social Media</option><option value="https://www.ringnews24.com/category/cheapest-boxing-tickets/"> Boxing Tickets</option><option value="https://www.ringnews24.com/category/supplements-for-boxing-mma/"> Supplements</option><option value="http://www.koboxingforum.com"> Boxing Forum</option><option value="https://www.ringnews24.com/2013/05/25/writers-articles-2/"> Our Writers</option></select></div>						
						<div id="gk-user-area">
								<a href="#" id="gk-login">Login</a>
								
								<a href="http://www.ringnews24.com/feed/" id="gk-rss">RSS</a>
							</div>
					</div>
	</header>


<section id="gk-content-top" class="gk-page">
	<ul id="top-menu" class="menu gk_normal"><li id="menu-item-42803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42803"><a href="https://www.ringnews24.com/category/boxing-news-and-views/">Breaking Boxing News</a></li>
<li id="menu-item-42789" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42789"><a href="https://www.ringnews24.com/category/boxing-news/">Boxing News</a></li>
<li id="menu-item-42791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42791"><a href="https://www.ringnews24.com/category/boxing-results/">Fight Results</a></li>
<li id="menu-item-42793" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42793"><a href="https://www.ringnews24.com/category/boxing-radio/">Radio</a></li>
<li id="menu-item-42788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42788"><a href="https://www.ringnews24.com/category/boxing-history/">Boxing History</a></li>
<li id="menu-item-42790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42790"><a href="https://www.ringnews24.com/category/female-boxing-news/">Female Boxing News</a></li>
<li id="menu-item-42792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42792"><a href="https://www.ringnews24.com/category/boxing-interviews/">Boxing Interviews</a></li>
<li id="menu-item-42429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42429"><a href="http://www.koboxingforum.com/">Boxing Forum</a></li>
</ul>	
		<div id="gk-social-icons">
		<a href="https://twitter.com/ringnews24" class="gk-twitter-icon" rel="nofollow">Twitter</a><a href="https://www.facebook.com/ringnews24" class="gk-facebook-icon" rel="nofollow">Facebook</a>	</div>
		
		<div id="gk-search">
		
<form method="get" id="searchform" action="https://www.ringnews24.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form>	</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>

<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								
								<div id="gk-top2">
					<div class="gk-page widget-area">
											</div>
					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="https://www.ringnews24.com" class="gk-home">Ring News 24</a><a href="https://www.ringnews24.com/category/boxing-news/" rel="category tag">Boxing News</a><span class="gk-current">A look back at 2018 with Star Boxing</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							
<section id="gk-mainbody">
	<div>
					
	<article id="post-78163" class="post-78163 post type-post status-publish format-standard has-post-thumbnail hentry category-boxing-news no-sidebar">
				<header>
			
<h1>
			A look back at 2018 with Star Boxing
		
	</h1>
<div class="subtitle-addons">
	<div class="author-name">
		<a href="https://www.ringnews24.com/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a>	</div>
	<div class="entry-date">
		11 January 2019	</div>
</div>

				
		</header>
		
		
		<figure class="featured-image">
		<img width="497" height="215" src="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Star Boxing" srcset="https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing.jpg 497w, https://www.ringnews24.com/wp-content/uploads/2015/09/Star-Boxing-300x130.jpg 300w" sizes="(max-width: 497px) 100vw, 497px" />		
								</figure>
						
		<div class="author-wrapper">
			<div class="author">
				
				<div class="author-avatar">
					<img alt='' src='https://secure.gravatar.com/avatar/1fb46dbb9d5c2be8a802f067149fe298?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1fb46dbb9d5c2be8a802f067149fe298?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' />				</div>
				<div class="author-name">
					<a href="https://www.ringnews24.com/author/press-release/" title="Posts by Press Release" rel="author">Press Release</a>				</div>
				<div class="newpost">
					<a href="http://www.ringnews24.com/2013/12/15/submit-your-boxing-article/">Write For Us</a>
				</div>
			</div>

			<div class="author-bio">
				
				<span>Press Release</span>
				<p>The article that you're about to read is an official announcement issued to Ring News 24 to publish as a press release.</p>
				
			</div>

			<a href="http://www.koboxingforum.com/forumdisplay.php?f=18" class="author-bio-banner" target="_blank"><img src="https://www.ringnews24.com/wp-content/uploads/2018/04/Visit-KO-Boxing-Forum.png" alt="KO Boxing Forum" /></a>

			
		</div>
		<section class="content">
			<div class="at-above-post addthis_tool" data-url="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/"></div><div class="addthis_toolbox addthis_default_style addthis_32x32_style">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_pinterest_share"></a>
<a class="addthis_button_reddit"></a>
</div><p>2018 was certainly a memorable year for Joe DeGuardia&#8217;s Star Boxing.</p>
<p>Leading a year of many highlights was the highly anticipated return of former WBO Super Lightweight Champion Chris Algieri. On November 30th, Algieri ended a two year hiatus from the ring, winning a shutout unanimous 10 round decision over Angel Hernandez, before a boisterous sold out crowd at The Paramount in Huntington, New York. Algieri made his first title run as a staple of Star Boxing&#8217;s Paramount shows, and the Hernandez bout was a true homecoming for the Huntington Long Islander whose loyal fans continue to give their unwavering support.</p>
<p>In dispatching Hernandez, Algieri left no doubt that the layoff has taken none of the luster off his superb boxing ability. In fact, under new trainer Andre Rozier, he has expanded his already ample fighting tool box. Algieri has never lost a fight at 140 lb. He is looking toward his next fight at the Hulu Theater at Madison Square Garden on January 18 (DAZN 6 PM) against stablemate Danny Gonzalez as the next step in a rapid path toward regaining the World Championship. The boxing world will be watching his return with great anticipation in 2019.</p><div class="k7ah3KzJ" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="gk-legend" data-style="style3"><strong>See Also</strong>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Link Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="3597679214"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<p>2018 also saw the successful return of Cletus &#8220;Hebrew Hammer&#8221; Seldin to the world stage. After looking sensational in his November 2017 appearance, destroying Roberto Ortiz (at the new Nassau Coliseum), Seldin suffered a severe elbow injury in his first loss against Yves Ulysses of Canada the following month, which required Tommy John Surgery. Cletus used the focus and determination he has so often displayed in the ring to work his way through a laborious rehabilitation and ten month layoff. Returning to the ring in November 2018, Seldin looked like a force of nature dispatching Nelson Lara in the opening round of a bout televised live on ESPN+ with his signature vicious body punching. Seldin appeared as sharp and as motivated as any time in his career, and left no doubt that he is a contender who must be reckoned with in the 140lb. division. Before his injury, Seldin had 3 fights in 4 months including two in consecutive months (November and December) on HBO, a distinction held by only Mike Tyson, Roy Jones and now Cletus Seldin. Less then 2 months after the Lara bout, Seldin will be back in the ring against veteran puncher, Hungarian, Adam Mate on January 26th, at Mohegan Sun, on his march toward a possible world title challenge at Super Lightweight in 2019.</p>
<p>In 2018, Joe &#8220;The Beast&#8221; Smith, Jr. returned to form, displaying his vaunted punching power, with a convincing one round knockout of Melvin Russell in their 10 round light heavyweight contest held at Mohegan Sun in June. The bout followed Smith&#8217;s valiant 2017 effort against top rated light heavyweight contender Sullivan Barrera. After registering a first round knockdown against Barrera, the always dangerous Joe Smith Jr. fought bravely for 10 rounds with a severely broken jaw &#8211; demonstrating his blue collar, union-made American grit. The bout marked a temporary setback for Smith, who after thrilling many audiences at the Paramount earlier in his career, was coming off a spectacular 2016 where he was runner-up for fighter of year, upset of year and knockout of the year following his successive knockout victories over Andrzej Fonfara and legendary <a href="http://www.ringnews24.com/tag/bernard-hopkins-boxing-news">Bernard Hopkins</a>. As one of the hardest punchers in boxing today, Smith is just one punch away from making himself a World Champion. Smith was scheduled to fight for the World Championship on December 15, 2018 at Madison Square Garden. However, World Champion Artur Beterbiev pulled out of the fight since his trainer was concerned that he needed more time to prepare against such a devastating puncher such as Joe Smith, Jr. Star Boxing promises to give Joe Smith, Jr. a World Championship title opportunity in 2019.</p>
<p>Rhode Island&#8217;s Native Warrior, Kali &#8220;KO Mequinonoag&#8221; Reis, is a force to be reckoned with in the welterweight division and 2018 was the year in which Reis reminded the world of women&#8217;s boxing of this fact. Reis, the former three-time world&#8217;s middleweight champion impressed the boxing world in her performance on HBO against undisputed champion and #1 pound-for-pound female fighter, Cecilia Braekhus, by scoring a knock down against the welterweight champion, forcing the action, and giving her all she could handle until the final bell. While Reis is already deserving of another title shot, she intends to keep active until she gets it. In her last bout on October 18th, Reis continued to display her power and skill scoring a 6th round knockout over Szilvia Szabados in Washington, DC. Reis now looks to return home, to New England and put her full warrior spirit on display at the Mohegan Sun on January 26th on her way to another title shot.</p>
<p>Another Star boxer who rose in prominence in 2018 was Danny &#8220;El Gallo&#8221; Gonzalez. Gonzalez made his mark before a sold-out crowd at the Paramount in September, in an engrossing, thrilling, tooth and nail war against Johnny &#8220;The Hitman&#8221; Hernandez. The crowd was so loud it was deafening. The bout was a war of attrition and proved to be a spectacular fight. Gonzalez finished a bit stronger as the ten-round epic battle came to a close with everyone standing and cheering. When the scores were read to a captivated crowd, the elated new ABO INTERCONTINENTAL CHAMPION, Danny Gonzalez dropped to his knees at the center of the ring in celebration. Gonzalez&#8217;s victory improved his record to 17-1-1 (6 KO&#8217;s). The win, his third straight of the year, all at the Paramount, earned him the accolade of ABO fighter of the year and a January 18, 2019 date with stablemate Chris Algieri at the Hulu Theater at Madison Square Garden. In Algieri, a former world champion, he will be facing he greatest test to date. With a possible world title opportunity and bragging rights in the Star Boxing stable hanging in the balance, Gonzalez is looking to make the new year the best of his career.</p>
<p>Star Boxing was also thrilled to add two notable fighters to its roster in 2018. In July, undefeated welterweight and Detroit native, Ronnie &#8220;Teflon Ron&#8221; Austion was signed to a promotional agreement. Austion returned to the ring in November under the Star Boxing banner scoring a knockout victory. Ronnie currently fights out of Las Vegas, Nevada, and with Star Boxing&#8217;s guidance, will look to continue to defend his undefeated record, while setting his sites on the ultimate goal of earning a world title. Austion will be showcasing his skills on January 26th at the Mohegan Sun.</p>
<p>In November, Star Boxing announced the signing of undefeated French super welterweight, former WBA Continental Middleweight Champion and current French Super Welterweight Champion, David Papot (Saint Nazaire, France, 22-0 3KO&#8217;s) to a long-term promotional agreement. Papot, who is currently rated the #9 Middleweight in the World (WBA) has successfully defended his French Super Welterweight title twice. Papot fought a total of thirty bouts with the French national team, reaching the quarter-finals of the European Championship. Star Boxing is poised to bring Papot international recognition and help him achieve world title aspirations.</p>
<p>2018 also saw the continuance of Star Boxing&#8217;s popular &#8220;Rockin Fights&#8221; series at the Paramount in Huntington, NY. CEO Joe DeGuardia showed his allegiance to the sport he loves by keeping the highly popular series as prolific as ever, maintaining its status as a centerpiece of the New York boxing scene. Star Boxing also continued its equally popular and long-standing &#8220;Slugfest at the Sun&#8221; series at Mohegan Sun Casino in Uncasville, CT.</p>
<p>Other Star Boxing fighters had success in 2018 including undefeated prospects Tyrone &#8220;Pretty Boy&#8221; James, who notched three victories in 2018, all at the Paramount, and displayed excellent punching power in maintaining his perfect record against Leo Carrizales in November, and &#8220;Action&#8221; Anthony Laureano who also tallied three victories in 2018, was named Connecticut&#8217;s Boxer of the Year and fights next on January 26th at Mohegan Sun.</p>
<p>Fellow Star Boxing stablemates, Joel Tambwe &#8220;Big Joe&#8221; Djeko, Anthony Karperis, Johnny Hernandez, Danny O&#8217;Connor, Dean Burrell, Tyrell Bostic, Courtney Pennington, Michael Stoute, Valerio Nocera, Angel Suarez and Wendy Toussaint join us all in looking forward to 2019!</p>
<p>Star Boxing found much success in 2018 from many different avenues including the sold out &#8220;Rockin&#8217; Fights&#8221; series, the Mohegan Sun series &#8220;Slugfest at the Sun,&#8221; that is now being televised by NESN, the appearance of Star Boxing fighters on the likes of HBO and DAZN and Star&#8217;s excellent and continuing successful relationships with many promoters in the industry such as Golden Boy, Top Rank, Matchroom Boxing, and others. With the success of quality veteran fighters, and the signing of new and exciting talent, 2019 will prove to be yet another successful year for Joe DeGuardia&#8217;s Star Boxing.</p>
<div class="posts-nav">
<div class="previous"><a href="https://www.ringnews24.com/2019/01/11/rivals-james-degale-and-chris-eubank-jr-kept-apart-incase-bad-blood-spills-over/" rel="prev">Rivals James DeGale and Chris Eubank Jr kept apart incase bad blood spills over</a></div>
<div class="next"><a href="https://www.ringnews24.com/2019/01/11/undefeated-cabrera-mioletti-faces-escalante-friday-at-battle-at-the-boat-119/" rel="next">Undefeated Cabrera Mioletti faces Escalante Friday at Battle at the Boat 119</a></div>
</div>
<div class="tag-section">
<div><span>Read more articles about: </span></div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="7447721437"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/"></div><!-- AddThis Share Buttons generic via filter on the_content -->			
									
		</section>
				
		

		
							<footer>
			</footer>
		</article>					
						
						</div>
	
	
</section>

		
							</div><!-- end of the #gk-content-wrap -->
			
									<aside id="gk-inset">
				<div id="widget_gk_nsp-11" class="box   onlyDesktop widget_gk_nsp"><h3 class="box-title">Boxing on TV</h3><div class="gk-nsp mobile_layout" data-cols="1" data-rows="1" data-links="1" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2018/11/19/deontay-wilder-v-tyson-fury-a-look-and-a-prediction-of-the-heavyweight-world-title-fight/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/60466-image_5bb537352bb22-widget_gk_nsp-11.jpg" alt="Deontay Wilder v Tyson Fury: A Look And A Prediction Of The Heavyweight World Title Fight" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2018/11/19/deontay-wilder-v-tyson-fury-a-look-and-a-prediction-of-the-heavyweight-world-title-fight/" title="Deontay Wilder v Tyson Fury: A Look And A Prediction Of The Heavyweight World Title Fight">Deontay Wilder v Tyson Fury: A Look And A Prediction&hellip;</a></h3></div></div></div></div><div class="gk-nsp-links"><div class="gk-nsp-links-scroll gk-nsp-pages-1"><ul class="gk-nsp-list gk-nsp-cols-1"><li><h4 class="gk-nsp-link-header"><a href="https://www.ringnews24.com/2018/05/02/live-boxing-tonight-boxing-on-tv-schedule-and-fixtures-may/" title="Boxing on TV – May">Boxing on TV – May</a></h4></li></ul></div></div></div></div><div id="widget_gk_nsp-5" class="box  color all widget_gk_nsp"><h3 class="box-title">Recommended</h3><div class="gk-nsp vertical" data-cols="1" data-rows="20" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/12/78176/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/dillian-whyte-whyte-boxing_3848984-widget_gk_nsp-5.jpg" alt="Dillian Whyte hits back at lowball offer to face Anthony Joshua, says he would knock out Wladimir Klitschko" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/12/78176/" title="Dillian Whyte hits back at lowball offer to face Anthony Joshua, says he would knock out Wladimir Klitschko">Dillian Whyte hits back at lowball offer to face Anthony&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/ruben-villa-defends-unbeaten-record-on-shobox/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/2018_Feb16_ThompsonBoxing_RubenVillaIV-1760_preview-widget_gk_nsp-5.jpeg" alt="Ruben Villa Defends Unbeaten Record On ShoBox" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/ruben-villa-defends-unbeaten-record-on-shobox/" title="Ruben Villa Defends Unbeaten Record On ShoBox">Ruben Villa Defends Unbeaten Record On ShoBox</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/matchroom-boxer-accuses-rival-of-stalling-his-career/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Matchroom-Boxing-widget_gk_nsp-5.jpg" alt="Matchroom boxer accuses rival of stalling his career" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/matchroom-boxer-accuses-rival-of-stalling-his-career/" title="Matchroom boxer accuses rival of stalling his career">Matchroom boxer accuses rival of stalling his career</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/amanda-serrano-makes-bold-statement-about-her-future-plans/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Amanda-entrenando-2-widget_gk_nsp-5.jpg" alt="Amanda Serrano makes BOLD statement about her future plans" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/amanda-serrano-makes-bold-statement-about-her-future-plans/" title="Amanda Serrano makes BOLD statement about her future plans">Amanda Serrano makes BOLD statement about her future plans</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/undefeated-cabrera-mioletti-faces-escalante-friday-at-battle-at-the-boat-119/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Battle-at-the-Boat-119-720x917-widget_gk_nsp-5.jpg" alt="Undefeated Cabrera Mioletti faces Escalante Friday at Battle at the Boat 119" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/undefeated-cabrera-mioletti-faces-escalante-friday-at-battle-at-the-boat-119/" title="Undefeated Cabrera Mioletti faces Escalante Friday at Battle at the Boat 119">Undefeated Cabrera Mioletti faces Escalante Friday at Battle at the&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Star-Boxing-widget_gk_nsp-5.jpg" alt="A look back at 2018 with Star Boxing" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" title="A look back at 2018 with Star Boxing">A look back at 2018 with Star Boxing</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/rivals-james-degale-and-chris-eubank-jr-kept-apart-incase-bad-blood-spills-over/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/image0021-widget_gk_nsp-5.jpg" alt="Rivals James DeGale and Chris Eubank Jr kept apart incase bad blood spills over" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/rivals-james-degale-and-chris-eubank-jr-kept-apart-incase-bad-blood-spills-over/" title="Rivals James DeGale and Chris Eubank Jr kept apart incase bad blood spills over">Rivals James DeGale and Chris Eubank Jr kept apart incase&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/danny-gonzalez-ready-for-chris-algieri-showdown/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Chris-Algieri-widget_gk_nsp-5.jpg" alt="Danny Gonzalez ready for Chris Algieri showdown" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/danny-gonzalez-ready-for-chris-algieri-showdown/" title="Danny Gonzalez ready for Chris Algieri showdown">Danny Gonzalez ready for Chris Algieri showdown</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/mayweather-sparring-partner-and-undefeated-canadian-southpaw-on-the-verge-of-a-boxing-breakthrough/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Floyd-Mayweather1-widget_gk_nsp-5.jpg" alt="Mayweather Sparring Partner and Undefeated Canadian Southpaw on the Verge of a Boxing Breakthrough" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/mayweather-sparring-partner-and-undefeated-canadian-southpaw-on-the-verge-of-a-boxing-breakthrough/" title="Mayweather Sparring Partner and Undefeated Canadian Southpaw on the Verge of a Boxing Breakthrough">Mayweather Sparring Partner and Undefeated Canadian Southpaw on the Verge&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/liam-smith-announces-new-3-year-contract/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Liam-Smith-1-widget_gk_nsp-5.jpg" alt="Liam Smith announces new 3 year contract" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/liam-smith-announces-new-3-year-contract/" title="Liam Smith announces new 3 year contract">Liam Smith announces new 3 year contract</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/looking-back-at-the-top-fights-of-2018-and-eyeing-the-best-of-2019/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/warringtonframpton-widget_gk_nsp-5.jpg" alt="Looking back at the top fights of 2018 and eyeing the best of 2019" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/looking-back-at-the-top-fights-of-2018-and-eyeing-the-best-of-2019/" title="Looking back at the top fights of 2018 and eyeing the best of 2019">Looking back at the top fights of 2018 and eyeing&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/badou-jack-and-marcus-browne-trade-verbal-jabs-ahead-of-january-19th-fight/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Badou-Jack1-widget_gk_nsp-5.jpg" alt="Badou Jack and Marcus Browne trade verbal jabs ahead of January 19th fight" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/badou-jack-and-marcus-browne-trade-verbal-jabs-ahead-of-january-19th-fight/" title="Badou Jack and Marcus Browne trade verbal jabs ahead of January 19th fight">Badou Jack and Marcus Browne trade verbal jabs ahead of&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/more-details-emerge-about-terence-crawford-vs-amir-khan-bob-arum-wants-to-make-the-fight-official-soon/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1429559480-amir-khan-widget_gk_nsp-5.jpg" alt="More Details Emerge About Terence Crawford vs. Amir Khan; Bob Arum Wants to Make The Fight Official Soon" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/more-details-emerge-about-terence-crawford-vs-amir-khan-bob-arum-wants-to-make-the-fight-official-soon/" title="More Details Emerge About Terence Crawford vs. Amir Khan; Bob Arum Wants to Make The Fight Official Soon">More Details Emerge About Terence Crawford vs. Amir Khan; Bob&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/some-potentially-interesting-matchups-for-2019/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Terence-Crawford-widget_gk_nsp-5.jpg" alt="Some Potentially Interesting Matchups for 2019" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/some-potentially-interesting-matchups-for-2019/" title="Some Potentially Interesting Matchups for 2019">Some Potentially Interesting Matchups for 2019</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/luis-munoz-reveals-all-the-pressure-is-on/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Dennis-Ceylan-widget_gk_nsp-5.jpg" alt="Luis Munoz reveals all the pressure is on" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/luis-munoz-reveals-all-the-pressure-is-on/" title="Luis Munoz reveals all the pressure is on">Luis Munoz reveals all the pressure is on</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/unbeaten-sonny-price-tops-bill-for-first-time/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Sonny-Boy-Price-Profile-Shot-widget_gk_nsp-5.jpg" alt="Unbeaten Sonny Price tops bill for first time" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/unbeaten-sonny-price-tops-bill-for-first-time/" title="Unbeaten Sonny Price tops bill for first time">Unbeaten Sonny Price tops bill for first time</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/battle-at-the-boat-119-weights/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Battle-at-the-Boat-119-720x917-widget_gk_nsp-5.jpg" alt="Battle at the Boat 119 Weights" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/battle-at-the-boat-119-weights/" title="Battle at the Boat 119 Weights">Battle at the Boat 119 Weights</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/oliver-flodin-reveals-what-he-has-to-defeat-abdul-khattab/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/sauerland_scroll-widget_gk_nsp-5.jpg" alt="Oliver Flodin reveals what he has to defeat Abdul Khattab" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/oliver-flodin-reveals-what-he-has-to-defeat-abdul-khattab/" title="Oliver Flodin reveals what he has to defeat Abdul Khattab">Oliver Flodin reveals what he has to defeat Abdul Khattab</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/tyson-fury-delivers-clear-message-to-archrival-deontay-wilder-as-rematch-negotiations-continue/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Wilder-Fury-widget_gk_nsp-5.jpg" alt="Tyson Fury delivers clear message to archrival Deontay Wilder as rematch negotiations continue" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/tyson-fury-delivers-clear-message-to-archrival-deontay-wilder-as-rematch-negotiations-continue/" title="Tyson Fury delivers clear message to archrival Deontay Wilder as rematch negotiations continue">Tyson Fury delivers clear message to archrival Deontay Wilder as&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2019/01/11/adrien-broner-believes-victory-over-manny-pacquiao-will-elevate-him-to-icon-status/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Adrien-Broner-widget_gk_nsp-5.jpg" alt="Adrien Broner believes victory over Manny Pacquiao will elevate him to "icon" status" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/01/11/adrien-broner-believes-victory-over-manny-pacquiao-will-elevate-him-to-icon-status/" title="Adrien Broner believes victory over Manny Pacquiao will elevate him to icon status">Adrien Broner believes victory over Manny Pacquiao will elevate him&hellip;</a></h3></div></div></div></div></div></div></div>			</aside>
								</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="text-2" class="box   onlyDesktop widget_text">			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="text-20" class="box   onlyDesktop widget_text"><h3 class="box-title">World Boxing Forum</h3>			<div class="textwidget"><center><a href=" http://www.koboxingforum.com/forumdisplay.php?f=18"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2018/04/boxingforumrn24ad2.png" width="235" height="500" border=" border=" /></a></center></div>
		</div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="text-12" class="box  widget_text col6 nth1 last4"><h3 class="box-title">Welcome</h3>			<div class="textwidget"><p>Welcome to <a href="https://www.ringnews24.com/category/boxing-news-and-views/">Ringnews24</a>; read the latest boxing news from around the world.</p>
<p>The site is run by boxing fans James Tonks and Lee Skavydis. </p>
<p>If you have any questions or suggestions, feel free to<a href="mailto:ringnews24@ringnews24.com" rel="nofollow">Email Us</a></p></div>
		</div><div id="text-13" class="box  widget_text col6 nth2 last4"><h3 class="box-title">Write for Ringnews24</h3>			<div class="textwidget"><ul>
<li><a href="https://www.ringnews24.com/2013/12/15/submit-your-boxing-article/" >Become a boxing writer on Ringnews24</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/writers-guide/#.VbJA6_mHwn8" >How to submit an article</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/qa-ringnews24/" >Writers Q/A</a></li>

<li><a href="https://www.ringnews24.com/2013/05/25/writers-articles-2/#.VbJJwvmHwn8" >Author List</a></li>

<li><a href="https://www.ringnews24.com/2015/09/01/writers-style-guide/#.Ve6ZTZeHwwI">Writers Style Guide</a><li>

<li><a href="https://www.ringnews24.com/2016/01/05/how-to-add-a-image/#.VouxVlJyNf0">How to add a photo to your article
</a><li>

</ul></div>
		</div><div id="text-14" class="box   onlyDesktop widget_text col6 nth3 last4"><h3 class="box-title">KO BOXING FORUM</h3>			<div class="textwidget"><ul>
	<li><a href="http://www.koboxingforum.com/forums/18-World-Boxing-Forum" target="_blank>World Boxing News</a></li>

	<li><a href="http://www.koboxingforum.com/forums/25-Boxing-History-Forum" target="_blank">Boxing History Forum</a></li>

<li><a href="http://www.koboxingforum.com/forums/27-Boxing-Training-and-Nutrition" target="_blank">Boxing Training and Nutrition</a></li>

<li><a href="http://www.koboxingforum.com/forums/20-Prediction-League" rel="nofollow"  target="_blank">Prediction League</a></li>

<li><a href="http://www.koboxingforum.com/forums/49-Buy-and-Sell-Boxing-Goods-on-eBay" target="_blank">Sell your eBay items</a></li>

<li><a href="http://www.koboxingforum.com/forums/17-Chatterbox" rel="nofollow"  target="_blank">Chatterbox</a></li>

<li><a href="http://www.koboxingforum.com/register.php"   target="_blank">Register Here</a></li>

</ul></div>
		</div><div id="text-15" class="box   onlyDesktop widget_text col6 nth4 last4"><h3 class="box-title">CONNECT WITH US</h3>			<div class="textwidget"><ul>

<li><a href="https://www.ringnews24.com/boxing-social-media/" >Social Media Wall</a></li>

<li><a href="https://twitter.com/ringnews24" rel="nofollow"  target="_blank">Twitter</a></li>

<li><a href="https://www.facebook.com/ringnews24" rel="nofollow"  target="_blank">Facebook</a></li>

<li><a href="https://www.pinterest.com/ringnews24/boxing/" rel="nofollow"  target="_blank">Pinterest</a></li>

<li><a href="https://www.ringnews24.com/feed/" target="_blank">RSS</a></li>

<li><a href="https://www.ringnews24.com/2018/02/20/about-us-2/" >About Us</a></li>

<li><a href="https://www.ringnews24.com/2013/05/26/contact-us/" >Contact Us</a></li>

</ul></div>
		</div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
				
		<div class="gk-copyrights">
			© Ringnews24		</div>
		
		
				
				
	</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="https://www.ringnews24.com/boxingauthor/" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="https://www.ringnews24.com/2019/01/11/a-look-back-at-2018-with-star-boxing/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
		
		
		
	



	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "5.0.3"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"ringnews24"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-54900234-1","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"AddThis","anonymous_profile_id":"wp-932a1e8a51a6107c59319588e16a24c5","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a3b52069ede608" async="async"></script><script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.scripts.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.typography.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.elements.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.template.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.js?ver=5.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringnews24.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/nsp.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/tabs.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/wp-embed.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.menu.js?ver=5.0.3'></script>
	
	
					<script type="text/javascript">
			  var _gaq = _gaq || [];
			  _gaq.push(['_setAccount', 'UA-54900234-2']);
			  _gaq.push(['_trackPageview']);
			
			  (function() {
			    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			  })();
			</script>

		</body>
</html>
