<!DOCTYPE html>
<html lang="en-GB" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head>
	<title>Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis -  - Boxing News - Ring News24</title>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis" />
<meta name="og:image" content="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career.

The 39-year-old Cuban southpaw " />
<meta name="og:url" content="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" />
	
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="/favicon.ico" />
	<link rel="pingback" href="https://www.ringnews24.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1250px; }
		#gk-mainbody-columns > aside { width: 22%;}
	#gk-mainbody-columns > section { width: 78%; }
	#gk-mainbody-columns { background-position: 78% 0!important; }
		
		#gk-inset { width: 27%;}
	#gk-content-wrap { width: 73%; }
	#gk-mainbody-columns > section { background-position: 73% 0!important; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"https://www.ringnews24.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"https://www.ringnews24.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		
<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis - Ring News 24" />
<meta property="og:description" content="Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career." />
<meta property="og:url" content="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" />
<meta property="og:site_name" content="Ring News 24" />
<meta property="article:publisher" content="https://www.facebook.com/ringnews24/" />
<meta property="article:author" content="https://www.facebook.com/anthony.cocks.5" />
<meta property="article:tag" content="Guillermo Rigondeaux" />
<meta property="article:tag" content="Liborio Solis" />
<meta property="article:tag" content="Vasiliy Lomachenko" />
<meta property="article:section" content="Breaking Boxing News" />
<meta property="article:published_time" content="2020-02-08T01:47:10+00:00" />
<meta property="og:image" content="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg" />
<meta property="og:image:secure_url" content="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg" />
<meta property="og:image:width" content="660" />
<meta property="og:image:height" content="495" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career." />
<meta name="twitter:title" content="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis - Ring News 24" />
<meta name="twitter:site" content="@ringnews24" />
<meta name="twitter:image" content="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg" />
<meta name="twitter:creator" content="@el_pollo_loco" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.ringnews24.com/#website","url":"https://www.ringnews24.com/","name":"Ring News 24","description":"Ring News | Daily Boxing News brought to you by Ring News 24","potentialAction":{"@type":"SearchAction","target":"https://www.ringnews24.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/#primaryimage","url":"https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg","width":660,"height":495},{"@type":"WebPage","@id":"https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/#webpage","url":"https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/","inLanguage":"en-GB","name":"Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis - Ring News 24","isPartOf":{"@id":"https://www.ringnews24.com/#website"},"primaryImageOfPage":{"@id":"https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/#primaryimage"},"datePublished":"2020-02-08T01:47:10+00:00","dateModified":"2020-02-08T01:47:10+00:00","author":{"@id":"https://www.ringnews24.com/#/schema/person/467745087882d647655c20b0775eca37"},"description":"Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career."},{"@type":["Person"],"@id":"https://www.ringnews24.com/#/schema/person/467745087882d647655c20b0775eca37","name":"Anthony Cocks","image":{"@type":"ImageObject","@id":"https://www.ringnews24.com/#authorlogo","url":"https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=96&d=mm&r=g","caption":"Anthony Cocks"},"description":"Australian-based boxing journalist Anthony Cocks has been covering the sport for over 15 years for various print and online publications. He refuses to believe that Roberto Duran ever lost to Tommy Hearns and says that Jeff Fenech would destroy Chuck Norris, Bruce Lee and Muhammad Ali on the same night.","sameAs":["https://www.facebook.com/anthony.cocks.5","https://twitter.com/el_pollo_loco"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ring News 24 &raquo; Feed" href="https://www.ringnews24.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringnews24.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=faef0ae6b0a65d14f02e2e286b2073d2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gavern-normalize-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/normalize.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/template.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/stuff.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.extensions.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/extensions.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.typography.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.elements.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.template.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/desktop.small.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.small.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/mobile.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/style1.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.ringnews24.com/wp-includes/css/dist/block-library/style.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='rss-retriever-css'  href='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/css/rss-retriever.css?ver=1.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ringnews24.com/wp-content/themes/News/fonts/fontawesome/font-awesome.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gk-nsp-css'  href='https://www.ringnews24.com/wp-content/plugins/GK-News-Show-Pro-master/gk-nsp.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.ringnews24.com/wp-includes/css/dashicons.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.ringnews24.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.ringnews24.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/ssb_bar_script.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/jquery.cookie.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/slideshow.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<link rel='https://api.w.org/' href='https://www.ringnews24.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringnews24.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringnews24.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.ringnews24.com/?p=87072' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F02%2F08%2Fguillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F02%2F08%2Fguillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis%2F&#038;format=xml" />
<link href="https://www.ringnews24.com/?opensearch_description=1" title="Ring News 24" rel="search" type="application/opensearchdescription+xml" /><link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-270x270.png" />
	
	<link href="https://fonts.googleapis.com/css?family=Hammersmith+One" rel="stylesheet" type="text/css" /><style type="text/css">
body,
h1, h2, h3, h4, h5, h6,
#main-menu > li li,
.bigtitle h3.header,
.box.badge-new .box-title::after,
.box.badge-popular .box-title::after,
.box.badge-top .box-title::after,
.box.bigtitle .box-title { font-family: Arial, Helvetica, sans-serif; }

#gk-logo.text,
#main-menu > li,
#top-menu,
#gk-user-area,
.box .box-title,
.gk-tabs-nav,
.nsphover .gk-nsp-category { font-family: 'Hammersmith One'; }

</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'https://www.ringnews24.com';
           $GK_TMPL_URL = 'https://www.ringnews24.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "width_height_opacity";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
	
		
		<link rel="stylesheet" type="text/css" href="https://www.ringnews24.com/wp-content/themes/News/css/override.css">

	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-5502369698975283",
	          enable_page_level_ads: true
	     });
	</script>
</head>
<body class="post-template-default single single-post postid-87072 single-format-standard" data-tablet-width="1030">
	<header id="gk-page-top">
		<div class="gk-page topbar">
						<h1>
				<a href="https://www.ringnews24.com" class="imageLogo"><img src="https://www.ringnews24.com/wp-content/uploads/2015/07/155x100.png" alt="" width="500" height="134" /></a>
			</h1>
						<div class="topad">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Homepage - Top advert 320x100 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:320px;height:100px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="2256322169"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
		</div>
		<div class="gk-page menubar">
			
			
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-42794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42794"><a href="http://www.ringnews24.com/">RN24</a></li>
<li id="menu-item-42984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42984"><a href="https://www.ringnews24.com/boxing-streaming/">Live Streaming</a></li>
<li id="menu-item-80605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80605"><a href="https://www.ringnews24.com/boxing-on-tv/">Boxing on TV</a></li>
<li id="menu-item-42805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42805"><a rel="nofollow" href="http://www.koboxingforum.com">Boxing Forum</a></li>
<li id="menu-item-64797" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-64797"><a title="Our Writers" href="https://www.ringnews24.com/2013/05/25/writers-articles-2/">Our Writers</a></li>
<li id="menu-item-80502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80502"><a href="https://www.ringnews24.com/boxing-news-aggregator/">Live Boxing News</a></li>
<li id="menu-item-83100" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83100"><a href="https://www.ringnews24.com/test/">TEST…</a></li>
</ul>				<div id="main-menu-mobile" class="menu-{menu slug}-container"><select onchange="window.location.href=this.value;"><option value="#">Select a page</option><option value="http://www.ringnews24.com/"> RN24</option><option value="https://www.ringnews24.com/boxing-streaming/"> Live Streaming</option><option value="https://www.ringnews24.com/boxing-on-tv/"> Boxing on TV</option><option value="http://www.koboxingforum.com"> Boxing Forum</option><option value="https://www.ringnews24.com/2013/05/25/writers-articles-2/"> Our Writers</option><option value="https://www.ringnews24.com/boxing-news-aggregator/"> Live Boxing News</option><option value="https://www.ringnews24.com/test/"> TEST…</option></select></div>						
						<div id="gk-user-area">
								<a href="#" id="gk-login">Login</a>
								
								<a href="https://www.ringnews24.com/feed/" id="gk-rss">RSS</a>
							</div>
					</div>
	</header>


<section id="gk-content-top" class="gk-page">
	<ul id="top-menu" class="menu gk_normal"><li id="menu-item-42803" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42803"><a href="https://www.ringnews24.com/category/boxing-news-and-views/">Breaking Boxing News</a></li>
<li id="menu-item-42789" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42789"><a href="https://www.ringnews24.com/category/boxing-news/">Boxing News</a></li>
<li id="menu-item-42791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42791"><a href="https://www.ringnews24.com/category/boxing-results/">Fight Results</a></li>
<li id="menu-item-42793" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42793"><a href="https://www.ringnews24.com/category/boxing-radio/">Radio</a></li>
<li id="menu-item-42788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42788"><a href="https://www.ringnews24.com/category/boxing-history/">Boxing History</a></li>
<li id="menu-item-42790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42790"><a href="https://www.ringnews24.com/category/female-boxing-news/">Female Boxing News</a></li>
<li id="menu-item-42792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42792"><a href="https://www.ringnews24.com/category/boxing-interviews/">Boxing Interviews</a></li>
<li id="menu-item-42429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42429"><a href="http://www.koboxingforum.com/">Boxing Forum</a></li>
</ul>	
		<div id="gk-social-icons">
		<a href="https://twitter.com/ringnews24" class="gk-twitter-icon" rel="nofollow">Twitter</a><a href="https://www.facebook.com/ringnews24" class="gk-facebook-icon" rel="nofollow">Facebook</a>	</div>
		
		<div id="gk-search">
		
<form method="get" id="searchform" action="https://www.ringnews24.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form>	</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>

<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								
								<div id="gk-top2">
					<div class="gk-page widget-area">
											</div>
					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="https://www.ringnews24.com" class="gk-home">Ring News 24</a><a href="https://www.ringnews24.com/category/boxing-news/" rel="category tag">Boxing News</a> <a href="https://www.ringnews24.com/category/boxing-news-and-views/" rel="category tag">Breaking Boxing News</a><span class="gk-current">Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							
<section id="gk-mainbody">
	<div>
					
	<article id="post-87072" class="post-87072 post type-post status-publish format-standard has-post-thumbnail hentry category-boxing-news category-boxing-news-and-views tag-guillermo-rigondeaux tag-liborio-solis tag-vasiliy-lomachenko no-sidebar">
				<header>
			
<h1>
			Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis
		
	</h1>
<div class="subtitle-addons">
	<div class="author-name">
		<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>	</div>
	<div class="entry-date">
		8 February 2020	</div>
</div>

				
		</header>
		
		
		<figure class="featured-image">
		<img width="660" height="495" src="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="rigondeaux" srcset="https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux.jpg 660w, https://www.ringnews24.com/wp-content/uploads/2020/02/rigondeaux-300x225.jpg 300w" sizes="(max-width: 660px) 100vw, 660px" />		
					<figcaption>Guillermo Rigondeaux. Photo credit: Getty Images</figcaption>			</figure>
						
		<div class="author-wrapper">
			<div class="author">
				
				<div class="author-avatar">
					<img alt='' src='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' />				</div>
				<div class="author-name">
					<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>				</div>
				<div class="newpost">
					<a href="http://www.ringnews24.com/2013/12/15/submit-your-boxing-article/">Write For Us</a>
				</div>
			</div>

			<div class="author-bio">
				
				<span>Anthony Cocks</span>
				<p>Australian-based boxing journalist Anthony Cocks has been covering the sport for over 15 years for various print and online publications. He refuses to believe that Roberto Duran ever lost to Tommy Hearns and says that Jeff Fenech would destroy Chuck Norris, Bruce Lee and Muhammad Ali on the same night.</p>
								<span>Follow Anthony Cocks on: </span>

				<a href="https://twitter.com/el_pollo_loco" rel="nofollow" target="_blank">Twitter</a> |				<a href="https://www.facebook.com/anthony.cocks.5" rel="nofollow" target="_blank">Facebook</a>				
			</div>

			<a href="http://www.koboxingforum.com/forumdisplay.php?f=18" class="author-bio-banner" target="_blank"><img src="https://www.ringnews24.com/wp-content/uploads/2018/04/Visit-KO-Boxing-Forum.png" alt="KO Boxing Forum" /></a>

			
		</div>
		<section class="content">
			<div class="at-above-post addthis_tool" data-url="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/"></div><div class="addthis_toolbox addthis_default_style addthis_32x32_style">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_pinterest_share"></a>
<a class="addthis_button_reddit"></a>
</div><p>Former WBA and WBO super bantamweight champion Guillermo Rigondeaux 19-1 (13) is convinced that a move down in weight to 118-pounds is the right move for his career.</p>
<p>The 39-year-old Cuban southpaw will face former unified super flyweight champion Liborio Solis 30-5-1 (14) for the vacant WBA ‘regular’ bantamweight title on the undercard of WBC featherweight champion Gary Russell Jr’s fifth title defence against Tugstsogt ‘King Tug’ Nyambayar at the PPL Center in Allentown, Pennsylvania this Saturday night.</p>
<p>Rigondeaux has fought as high as super featherweight, where he suffered his lone professional loss to Vasiliy Lomachenko by sixth round stoppage at Madison Square Garden in New York two years ago.</p><div class="cLgniCzv" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="gk-legend" data-style="style3"><strong>See Also</strong>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Link Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="3597679214"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<p>&#8220;This is really my weight – 118,” Rigondeaux said. “I fought at 122, but I feel very comfortable at 118.</p>
<p>“Boxing is like mathematics, so we&#8217;re going to adjust to whatever my opponent brings. We can box and also, what you saw in my last fight, we can pressure. I can also bring that tomorrow.&#8221;</p>
<p>Venezuelan Solis, 37, says he still has the hunger and yearns to be a world champion once again.</p>
<p>&#8220;There&#8217;s always that same hunger to win a championship again. It&#8217;s been a while, so I want it back,” Solis said.</p>
<p>“With faith in God, I will get it back tomorrow. I want to state that me and Guillermo are both warriors. We&#8217;re both going to give a great show out there.</p>
<p>“If he comes out boxing, then I&#8217;ll box him. If he comes out with pressure, like he did in his last fight, then I will come out that way.</p>
<p>“We both want this fight. We know it&#8217;s a great opportunity and I&#8217;m going to show the best of me tomorrow.&#8221;</p>
<div class="posts-nav">
<div class="previous"><a href="https://www.ringnews24.com/2020/02/08/gary-russell-jr-focusing-on-himself-ahead-of-title-defence-against-tugstsogt-nyambayar/" rel="prev">Gary Russell Jr focusing on himself ahead of title defence against Tugstsogt Nyambayar</a></div>
<div class="next"></div>
</div>
<div class="tag-section">
<div><span>Read more articles about: </span><a href="https://www.ringnews24.com/tag/guillermo-rigondeaux/" rel="tag">Guillermo Rigondeaux</a>, <a href="https://www.ringnews24.com/tag/liborio-solis/" rel="tag">Liborio Solis</a>, <a href="https://www.ringnews24.com/tag/vasiliy-lomachenko/" rel="tag">Vasiliy Lomachenko</a></div>
</div>
<p><img class="wp-image-83458 size-full aligncenter" style="float: left;" src="https://www.ringnews24.com/wp-content/uploads/2019/08/red-speech-300x267.png" alt="red-speech-300&times;267" width="120" height="80" /></p>
<p style="padding-left: 60px;"><span style="text-decoration: underline;"><a href="https://www.koboxingforum.com/articles" target="_blank" rel="noopener"><strong>Click Here</strong></a></span>, If you wish to add a<strong> COMMENT </strong>to the above article or any of the Ringnews24 boxing articles.</p>
<p style="padding-left: 60px;">&nbsp;</p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="7447721437"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/"></div><!-- AddThis Share Buttons generic via filter on the_content -->			
									
		</section>
				
		

		
							<footer>
			</footer>
		</article>					
						
						</div>
	
	
</section>

		
							</div><!-- end of the #gk-content-wrap -->
			
									<aside id="gk-inset">
				<div id="widget_gk_nsp-5" class="box  color all widget_gk_nsp"><h3 class="box-title">Recommended</h3><div class="gk-nsp vertical" data-cols="1" data-rows="20" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/rigondeaux-widget_gk_nsp-5.jpg" alt="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" title="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis">Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/08/gary-russell-jr-focusing-on-himself-ahead-of-title-defence-against-tugstsogt-nyambayar/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/gary-russell-king-tug-widget_gk_nsp-5.jpg" alt="Gary Russell Jr focusing on himself ahead of title defence against Tugstsogt Nyambayar" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/08/gary-russell-jr-focusing-on-himself-ahead-of-title-defence-against-tugstsogt-nyambayar/" title="Gary Russell Jr focusing on himself ahead of title defence against Tugstsogt Nyambayar">Gary Russell Jr focusing on himself ahead of title defence&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/kubrat-pulev-sends-warning-to-anthony-joshua/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/joshua-pulev-12-widget_gk_nsp-5.jpg" alt="Kubrat Pulev sends warning to Anthony Joshua" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/kubrat-pulev-sends-warning-to-anthony-joshua/" title="Kubrat Pulev sends warning to Anthony Joshua">Kubrat Pulev sends warning to Anthony Joshua</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/kell-brook-wants-second-world-championship-in-2020-says-amir-khan-fight-will-never-happen/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Kell-Brook-1-widget_gk_nsp-5.jpg" alt="Kell Brook wants second world championship in 2020, says Amir Khan fight will never happen" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/kell-brook-wants-second-world-championship-in-2020-says-amir-khan-fight-will-never-happen/" title="Kell Brook wants second world championship in 2020, says Amir Khan fight will never happen">Kell Brook wants second world championship in 2020, says Amir&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/daniel-dubois-promises-to-knockout-joe-joyce-at-the-o2-arena/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1204625261.jpg.0-widget_gk_nsp-5.jpg" alt="Daniel Dubois promises to knockout Joe Joyce at the O2 Arena" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/daniel-dubois-promises-to-knockout-joe-joyce-at-the-o2-arena/" title="Daniel Dubois promises to knockout Joe Joyce at the O2 Arena">Daniel Dubois promises to knockout Joe Joyce at the O2&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/carlos-takam-added-to-rockin-fights-38/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Star-Boxing-widget_gk_nsp-5.jpg" alt="Carlos Takam added to "Rockin Fights 38"" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/carlos-takam-added-to-rockin-fights-38/" title="Carlos Takam added to Rockin Fights 38">Carlos Takam added to "Rockin Fights 38"</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/lewkowicz-meets-panamanian-president-cortizo-to-rejuvenate-countrys-amateur-boxing-program/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Sampson-Boxing-widget_gk_nsp-5.jpg" alt="Lewkowicz meets Panamanian President Cortizo to rejuvenate country's amateur boxing program" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/lewkowicz-meets-panamanian-president-cortizo-to-rejuvenate-countrys-amateur-boxing-program/" title="Lewkowicz meets Panamanian President Cortizo to rejuvenate country's amateur boxing program">Lewkowicz meets Panamanian President Cortizo to rejuvenate country's amateur boxing&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/kylie-hutt-signs-with-tony-tolj-and-dragon-fire-boxing/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/60463250_2274307002655382_6635205245133651968_o-widget_gk_nsp-5.jpg" alt="Kylie Hutt signs with Tony Tolj and Dragon Fire Boxing" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/kylie-hutt-signs-with-tony-tolj-and-dragon-fire-boxing/" title="Kylie Hutt signs with Tony Tolj and Dragon Fire Boxing">Kylie Hutt signs with Tony Tolj and Dragon Fire Boxing</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/joe-joyce-vs-daniel-dubois-confirmed-for-the-o2/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/daniel-dubois-widget_gk_nsp-5.jpg" alt="Joe Joyce vs Daniel Dubois confirmed for the O2" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/joe-joyce-vs-daniel-dubois-confirmed-for-the-o2/" title="Joe Joyce vs Daniel Dubois confirmed for the O2">Joe Joyce vs Daniel Dubois confirmed for the O2</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/07/richard-medina-and-hector-coronado-return-this-friday-in-matamoros-mexico/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/unnamed158-widget_gk_nsp-5.jpg" alt="Richard Medina and Hector Coronado Return This Friday in Matamoros Mexico" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/07/richard-medina-and-hector-coronado-return-this-friday-in-matamoros-mexico/" title="Richard Medina and Hector Coronado Return This Friday in Matamoros Mexico">Richard Medina and Hector Coronado Return This Friday in Matamoros&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/sam-eggington-added-to-skydome-card-in-coventry/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/sam-eggington-dale-evans-boxing_3365337-widget_gk_nsp-5.jpg" alt="Sam Eggington added to Skydome card in Coventry" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/sam-eggington-added-to-skydome-card-in-coventry/" title="Sam Eggington added to Skydome card in Coventry">Sam Eggington added to Skydome card in Coventry</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/gary-russell-jr-and-tugstsogt-nyambayar-goe-face-to-face-at-presser/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Gary-Russell-Jr-widget_gk_nsp-5.jpg" alt="Gary Russell Jr and Tugstsogt Nyambayar go face-to-face at presser" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/gary-russell-jr-and-tugstsogt-nyambayar-goe-face-to-face-at-presser/" title="Gary Russell Jr and Tugstsogt Nyambayar go face-to-face at presser">Gary Russell Jr and Tugstsogt Nyambayar go face-to-face at presser</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/matchroom-boxing-announce-new-partner/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Matchroom-Boxing-widget_gk_nsp-5.jpg" alt="Matchroom Boxing announce new partner" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/matchroom-boxing-announce-new-partner/" title="Matchroom Boxing announce new partner">Matchroom Boxing announce new partner</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/reid-boxing-of-las-vegas-debuts-with-professional-card/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/unnamed157-widget_gk_nsp-5.jpg" alt="Reid Boxing of Las Vegas debuts with professional card" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/reid-boxing-of-las-vegas-debuts-with-professional-card/" title="Reid Boxing of Las Vegas debuts with professional card">Reid Boxing of Las Vegas debuts with professional card</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/derrick-webster-battles-gabriel-pham-in-south-jersey-super-middleweight-showdown/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Derrick-Webster-widget_gk_nsp-5.jpg" alt="Derrick Webster battles Gabriel Pham in South Jersey Super Middleweight Showdown" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/derrick-webster-battles-gabriel-pham-in-south-jersey-super-middleweight-showdown/" title="Derrick Webster battles Gabriel Pham in South Jersey Super Middleweight Showdown">Derrick Webster battles Gabriel Pham in South Jersey Super Middleweight&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/daniel-roman-seeks-immediate-rematch-with-murodjon-akhmadaliev/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/roman-23-widget_gk_nsp-5.jpg" alt="Daniel Roman Seeks Immediate Rematch with Murodjon Akhmadaliev" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/daniel-roman-seeks-immediate-rematch-with-murodjon-akhmadaliev/" title="Daniel Roman Seeks Immediate Rematch with Murodjon Akhmadaliev">Daniel Roman Seeks Immediate Rematch with Murodjon Akhmadaliev</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/ortiz-defends-pa-state-lightweight-title-in-philly-vs-philly-main-event/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/unnamed156-widget_gk_nsp-5.jpg" alt="Ortiz Defends PA State Lightweight Title In Philly vs. Philly Main Event" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/ortiz-defends-pa-state-lightweight-title-in-philly-vs-philly-main-event/" title="Ortiz Defends PA State Lightweight Title In Philly vs. Philly Main Event">Ortiz Defends PA State Lightweight Title In Philly vs. Philly&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/john-riel-casimero-says-he-holds-no-fear-of-naoya-inoue-ahead-of-their-unification-clash/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/casimero-tete09-widget_gk_nsp-5.jpg" alt="John Riel Casimero says he holds no fear of Naoya Inoue ahead of their unification clash" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/john-riel-casimero-says-he-holds-no-fear-of-naoya-inoue-ahead-of-their-unification-clash/" title="John Riel Casimero says he holds no fear of Naoya Inoue ahead of their unification clash">John Riel Casimero says he holds no fear of Naoya&hellip;</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/tyson-fury-prepared-to-face-anthony-joshua-under-one-condition/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Tyson_Fury_Apollo_Creed-widget_gk_nsp-5.jpg" alt="Tyson Fury prepared to face Anthony Joshua under one condition" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/tyson-fury-prepared-to-face-anthony-joshua-under-one-condition/" title="Tyson Fury prepared to face Anthony Joshua under one condition">Tyson Fury prepared to face Anthony Joshua under one condition</a></h3></div></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0;"><div class="gk-nsp-image-wrap"><a href="https://www.ringnews24.com/2020/02/06/michael-zerafa-predicts-jeff-horn-victory-over-tim-tszyu/" class="gk-image-link"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Horn-Zerafa-fight-widget_gk_nsp-5.jpg" alt="Michael Zerafa predicts Jeff Horn victory over Tim Tszyu" class="gk-nsp-image"  height="68" width="80" /></a></div><div class="gk-nsp-content-wrap"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/06/michael-zerafa-predicts-jeff-horn-victory-over-tim-tszyu/" title="Michael Zerafa predicts Jeff Horn victory over Tim Tszyu">Michael Zerafa predicts Jeff Horn victory over Tim Tszyu</a></h3></div></div></div></div></div></div></div>			</aside>
								</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="text-2" class="box   onlyDesktop widget_text">			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="text-20" class="box   onlyDesktop widget_text"><h3 class="box-title">World Boxing Forum</h3>			<div class="textwidget"><center><a href=" http://www.koboxingforum.com/forumdisplay.php?f=18"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2018/04/boxingforumrn24ad2.png" width="235" height="500" border=" border=" /></a></center></div>
		</div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="text-12" class="box  widget_text col6 nth1 last4"><h3 class="box-title">Welcome</h3>			<div class="textwidget"><p>Welcome to Ringnews24; read the latest boxing news from around the world.</p>
<p>The site is run by boxing fans James Tonks and Lee Daley. </p>
<p>If you have any questions or suggestions, feel free to<a href="mailto:ringnews24@ringnews24.com" rel="nofollow">Email Us</a></p>

</div>
		</div><div id="text-13" class="box  widget_text col6 nth2 last4"><h3 class="box-title">Write for Ringnews24</h3>			<div class="textwidget"><ul>
<li><a href="https://www.ringnews24.com/2013/12/15/submit-your-boxing-article/" >Become a boxing writer on Ringnews24</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/writers-guide/#.VbJA6_mHwn8" >How to submit an article</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/qa-ringnews24/" >Writers Q/A</a></li>

<li><a href="https://www.ringnews24.com/2013/05/25/writers-articles-2/#.VbJJwvmHwn8" >Author List</a></li>

<li><a href="https://www.ringnews24.com/2015/09/01/writers-style-guide/#.Ve6ZTZeHwwI">Writers Style Guide</a><li>

<li><a href="https://www.ringnews24.com/2016/01/05/how-to-add-a-image/#.VouxVlJyNf0">How to add a photo to your article
</a><li>

</ul></div>
		</div><div id="text-14" class="box   onlyDesktop widget_text col6 nth3 last4"><h3 class="box-title">KO BOXING FORUM</h3>			<div class="textwidget"><ul>
	<li><a href="http://www.koboxingforum.com/forums/18-World-Boxing-Forum" target="_blank>World Boxing News</a></li>

	<li><a href="http://www.koboxingforum.com/forums/25-Boxing-History-Forum" target="_blank" rel="noopener noreferrer">Boxing History Forum</a></li>

<li><a href="http://www.koboxingforum.com/forums/27-Boxing-Training-and-Nutrition" target="_blank" rel="noopener noreferrer">Boxing Training and Nutrition</a></li>

<li><a href="http://www.koboxingforum.com/forums/20-Prediction-League" rel="nofollow noopener noreferrer" target="_blank">Prediction League</a></li>

<li><a href="http://www.koboxingforum.com/forums/49-Buy-and-Sell-Boxing-Goods-on-eBay" target="_blank" rel="noopener noreferrer">Sell your eBay items</a></li>

<li><a href="http://www.koboxingforum.com/forums/17-Chatterbox" rel="nofollow noopener noreferrer" target="_blank">Chatterbox</a></li>

<li><a href="http://www.koboxingforum.com/register.php" target="_blank" rel="noopener noreferrer">Register Here</a></li>

</ul></div>
		</div><div id="text-15" class="box   onlyDesktop widget_text col6 nth4 last4"><h3 class="box-title">CONNECT WITH US</h3>			<div class="textwidget"><ul>

<li><a href="https://www.ringnews24.com/boxing-social-media/" >Social Media Wall</a></li>

<li><a href="https://twitter.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Twitter</a></li>

<li><a href="https://www.facebook.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Facebook</a></li>

<li><a href="https://www.pinterest.com/ringnews24/boxing/" rel="nofollow noopener noreferrer" target="_blank">Pinterest</a></li>

<li><a href="https://www.ringnews24.com/feed/" target="_blank" rel="noopener noreferrer">RSS</a></li>

<li><a href="https://www.ringnews24.com/2018/02/20/about-us-2/" >About Us</a></li>

<li><a href="https://www.ringnews24.com/2013/05/26/contact-us/" >Contact Us</a></li>

</ul>
</div>
		</div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
				
		<div class="gk-copyrights">
			© Ringnews24		</div>
		
		
				
				
	</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="https://www.ringnews24.com/boxingauthor/" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
		
		
		
	



	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"ringnews24"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-54900234-1","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-932a1e8a51a6107c59319588e16a24c5","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a3b52069ede608" async="async"></script><script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.scripts.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.typography.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.elements.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.template.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringnews24.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rss_retriever = {"ajax_url":"https:\/\/www.ringnews24.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/js/rss-retriever-ajax.js?ver=1.5.5'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/nsp.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/tabs.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/GK-News-Show-Pro-master/gk-nsp.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.ringnews24.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/wp-embed.min.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.menu.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
	
	
					<script type="text/javascript">
			  var _gaq = _gaq || [];
			  _gaq.push(['_setAccount', 'UA-54900234-2']);
			  _gaq.push(['_trackPageview']);
			
			  (function() {
			    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			  })();
			</script>

		</body>
</html>

<!-- Dynamic page generated in 1.204 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-02-08 01:47:40 -->

<!-- Compression = gzip -->