<!DOCTYPE html>
<html lang="en-GB" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head>
	<title>Eddie Hearn calls Billy Joe Saunders &quot;idiotic&quot; for his latest video gaffe -  - Boxing News - Ring News24</title>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="Eddie Hearn calls Billy Joe Saunders &quot;idiotic&quot; for his latest video gaffe" />
<meta name="og:image" content="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence.

The WBO super middl" />
<meta name="og:url" content="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" />
	
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="/favicon.ico" />
	<link rel="pingback" href="https://www.ringnews24.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1250px; }
		#gk-mainbody-columns > aside { width: 22%;}
	#gk-mainbody-columns > section { width: 78%; }
	#gk-mainbody-columns { background-position: 78% 0!important; }
		
		#gk-inset { width: 27%;}
	#gk-content-wrap { width: 73%; }
	#gk-mainbody-columns > section { background-position: 73% 0!important; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"https://www.ringnews24.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"https://www.ringnews24.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		
<!-- This site is optimized with the Yoast SEO plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Eddie Hearn calls Billy Joe Saunders &quot;idiotic&quot; for his latest video gaffe - Ring News 24" />
<meta property="og:description" content="Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence." />
<meta property="og:url" content="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" />
<meta property="og:site_name" content="Ring News 24" />
<meta property="article:publisher" content="https://www.facebook.com/ringnews24/" />
<meta property="article:author" content="https://www.facebook.com/anthony.cocks.5" />
<meta property="article:tag" content="Billy Joe Saunders" />
<meta property="article:tag" content="Canelo Alvarez" />
<meta property="article:tag" content="Eddie Hearn" />
<meta property="article:section" content="Breaking Boxing News" />
<meta property="article:published_time" content="2020-04-01T01:55:16+00:00" />
<meta property="og:image" content="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg" />
<meta property="og:image:secure_url" content="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg" />
<meta property="og:image:width" content="770" />
<meta property="og:image:height" content="511" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence." />
<meta name="twitter:title" content="Eddie Hearn calls Billy Joe Saunders &quot;idiotic&quot; for his latest video gaffe - Ring News 24" />
<meta name="twitter:site" content="@ringnews24" />
<meta name="twitter:image" content="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg" />
<meta name="twitter:creator" content="@el_pollo_loco" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.ringnews24.com/#website","url":"https://www.ringnews24.com/","name":"Ring News 24","inLanguage":"en-GB","description":"Ring News | Daily Boxing News brought to you by Ring News 24","potentialAction":{"@type":"SearchAction","target":"https://www.ringnews24.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/#primaryimage","inLanguage":"en-GB","url":"https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg","width":770,"height":511},{"@type":"WebPage","@id":"https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/#webpage","url":"https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/","name":"Eddie Hearn calls Billy Joe Saunders &quot;idiotic&quot; for his latest video gaffe - Ring News 24","isPartOf":{"@id":"https://www.ringnews24.com/#website"},"inLanguage":"en-GB","primaryImageOfPage":{"@id":"https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/#primaryimage"},"datePublished":"2020-04-01T01:55:16+00:00","dateModified":"2020-04-01T01:55:16+00:00","author":{"@id":"https://www.ringnews24.com/#/schema/person/467745087882d647655c20b0775eca37"},"description":"Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as \u201cidiotic\u201d for releasing a video in which he appears to condone Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as \u201cidiotic\u201d for releasing a video in which he appears to condone domestic violence."},{"@type":["Person"],"@id":"https://www.ringnews24.com/#/schema/person/467745087882d647655c20b0775eca37","name":"Anthony Cocks","image":{"@type":"ImageObject","@id":"https://www.ringnews24.com/#authorlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=96&d=mm&r=g","caption":"Anthony Cocks"},"description":"Australian-based boxing journalist Anthony Cocks has been covering the sport for over 15 years for various print and online publications. He refuses to believe that Roberto Duran ever lost to Tommy Hearns and says that Jeff Fenech would destroy Chuck Norris, Bruce Lee and Muhammad Ali on the same night.","sameAs":["https://www.facebook.com/anthony.cocks.5","https://twitter.com/el_pollo_loco"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ring News 24 &raquo; Feed" href="https://www.ringnews24.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringnews24.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=faef0ae6b0a65d14f02e2e286b2073d2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gavern-normalize-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/normalize.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/template.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/stuff.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.extensions.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/extensions.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.typography.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.elements.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.template.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/desktop.small.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.small.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/mobile.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/style1.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.ringnews24.com/wp-includes/css/dist/block-library/style.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='rss-retriever-css'  href='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/css/rss-retriever.css?ver=1.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ringnews24.com/wp-content/themes/News/fonts/fontawesome/font-awesome.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.ringnews24.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.ringnews24.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=faef0ae6b0a65d14f02e2e286b2073d2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/ssb_bar_script.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/ultimate-bar/js/jquery.cookie.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/slideshow.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<link rel='https://api.w.org/' href='https://www.ringnews24.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringnews24.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringnews24.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.ringnews24.com/?p=88522' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F04%2F01%2Feddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F04%2F01%2Feddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe%2F&#038;format=xml" />
<link href="https://www.ringnews24.com/?opensearch_description=1" title="Ring News 24" rel="search" type="application/opensearchdescription+xml" /><link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-270x270.png" />
	
	<link href="https://fonts.googleapis.com/css?family=Hammersmith+One" rel="stylesheet" type="text/css" /><style type="text/css">
body,
h1, h2, h3, h4, h5, h6,
#main-menu > li li,
.bigtitle h3.header,
.box.badge-new .box-title::after,
.box.badge-popular .box-title::after,
.box.badge-top .box-title::after,
.box.bigtitle .box-title { font-family: Arial, Helvetica, sans-serif; }

#gk-logo.text,
#main-menu > li,
#top-menu,
#gk-user-area,
.box .box-title,
.gk-tabs-nav,
.nsphover .gk-nsp-category { font-family: 'Hammersmith One'; }

</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'https://www.ringnews24.com';
           $GK_TMPL_URL = 'https://www.ringnews24.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "width_height_opacity";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
	
		
		<link rel="stylesheet" type="text/css" href="https://www.ringnews24.com/wp-content/themes/News/css/override.css">

	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-5502369698975283",
	          enable_page_level_ads: true
	     });
	</script>
</head>
<body class="post-template-default single single-post postid-88522 single-format-standard" data-tablet-width="1030">
	<header id="gk-page-top">
		<div class="gk-page topbar">
						<h1>
				<a href="https://www.ringnews24.com" class="imageLogo"><img src="https://www.ringnews24.com/wp-content/uploads/2015/07/155x100.png" alt="" width="500" height="134" /></a>
			</h1>
						<div class="topad">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Homepage - Top advert 320x100 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:320px;height:100px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="2256322169"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
		</div>
		<div class="gk-page menubar">
			
			
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-42794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42794"><a href="http://www.ringnews24.com/">RN24</a></li>
<li id="menu-item-42984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42984"><a href="https://www.ringnews24.com/boxing-streaming/">Live Streaming</a></li>
<li id="menu-item-80605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80605"><a href="https://www.ringnews24.com/boxing-on-tv/">Boxing on TV</a></li>
<li id="menu-item-42805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42805"><a rel="nofollow" href="http://www.koboxingforum.com">Boxing Forum</a></li>
<li id="menu-item-64797" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-64797"><a title="Our Writers" href="https://www.ringnews24.com/2013/05/25/writers-articles-2/">Our Writers</a></li>
<li id="menu-item-80502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80502"><a href="https://www.ringnews24.com/boxing-news-aggregator/">Live Boxing News</a></li>
<li id="menu-item-83100" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83100"><a href="https://www.ringnews24.com/test/">TEST…</a></li>
</ul>				<div id="main-menu-mobile" class="menu-{menu slug}-container"><select onchange="window.location.href=this.value;"><option value="#">Select a page</option><option value="http://www.ringnews24.com/"> RN24</option><option value="https://www.ringnews24.com/boxing-streaming/"> Live Streaming</option><option value="https://www.ringnews24.com/boxing-on-tv/"> Boxing on TV</option><option value="http://www.koboxingforum.com"> Boxing Forum</option><option value="https://www.ringnews24.com/2013/05/25/writers-articles-2/"> Our Writers</option><option value="https://www.ringnews24.com/boxing-news-aggregator/"> Live Boxing News</option><option value="https://www.ringnews24.com/test/"> TEST…</option></select></div>						
						<div id="gk-user-area">
								<a href="#" id="gk-login">Login</a>
								
								<a href="https://www.ringnews24.com/feed/" id="gk-rss">RSS</a>
							</div>
					</div>
	</header>


<section id="gk-content-top" class="gk-page">
	<ul id="top-menu" class="menu gk_normal"><li id="menu-item-42803" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42803"><a href="https://www.ringnews24.com/category/boxing-news-and-views/">Breaking Boxing News</a></li>
<li id="menu-item-42789" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42789"><a href="https://www.ringnews24.com/category/boxing-news/">Boxing News</a></li>
<li id="menu-item-42791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42791"><a href="https://www.ringnews24.com/category/boxing-results/">Fight Results</a></li>
<li id="menu-item-42793" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42793"><a href="https://www.ringnews24.com/category/boxing-radio/">Radio</a></li>
<li id="menu-item-42788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42788"><a href="https://www.ringnews24.com/category/boxing-history/">Boxing History</a></li>
<li id="menu-item-42790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42790"><a href="https://www.ringnews24.com/category/female-boxing-news/">Female Boxing News</a></li>
<li id="menu-item-42792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42792"><a href="https://www.ringnews24.com/category/boxing-interviews/">Boxing Interviews</a></li>
<li id="menu-item-42429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42429"><a href="http://www.koboxingforum.com/">Boxing Forum</a></li>
</ul>	
		<div id="gk-social-icons">
		<a href="https://twitter.com/ringnews24" class="gk-twitter-icon" rel="nofollow">Twitter</a><a href="https://www.facebook.com/ringnews24" class="gk-facebook-icon" rel="nofollow">Facebook</a>	</div>
		
		<div id="gk-search">
		
<form method="get" id="searchform" action="https://www.ringnews24.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form>	</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>

<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								
								<div id="gk-top2">
					<div class="gk-page widget-area">
											</div>
					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="https://www.ringnews24.com" class="gk-home">Ring News 24</a><a href="https://www.ringnews24.com/category/boxing-news/" rel="category tag">Boxing News</a> <a href="https://www.ringnews24.com/category/boxing-news-and-views/" rel="category tag">Breaking Boxing News</a><span class="gk-current">Eddie Hearn calls Billy Joe Saunders &#8220;idiotic&#8221; for his latest video gaffe</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							
<section id="gk-mainbody">
	<div>
					
	<article id="post-88522" class="post-88522 post type-post status-publish format-standard has-post-thumbnail hentry category-boxing-news category-boxing-news-and-views tag-billy-joe-saunders tag-canelo-alvarez-boxing-news tag-eddie-hearn no-sidebar">
				<header>
			
<h1>
			Eddie Hearn calls Billy Joe Saunders &#8220;idiotic&#8221; for his latest video gaffe
		
	</h1>
<div class="subtitle-addons">
	<div class="author-name">
		<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>	</div>
	<div class="entry-date">
		1 April 2020	</div>
</div>

				
		</header>
		
		
		<figure class="featured-image">
		<img width="770" height="511" src="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770&#215;511" srcset="https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511.jpg 770w, https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-300x199.jpg 300w, https://www.ringnews24.com/wp-content/uploads/2019/11/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-768x510.jpg 768w" sizes="(max-width: 770px) 100vw, 770px" />		
					<figcaption>Billy Joe Saunders vs Marcelo Coceres.
Photo credit: German Villasenor</figcaption>			</figure>
						
		<div class="author-wrapper">
			<div class="author">
				
				<div class="author-avatar">
					<img alt='' src='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' />				</div>
				<div class="author-name">
					<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>				</div>
				<div class="newpost">
					<a href="http://www.ringnews24.com/2013/12/15/submit-your-boxing-article/">Write For Us</a>
				</div>
			</div>

			<div class="author-bio">
				
				<span>Anthony Cocks</span>
				<p>Australian-based boxing journalist Anthony Cocks has been covering the sport for over 15 years for various print and online publications. He refuses to believe that Roberto Duran ever lost to Tommy Hearns and says that Jeff Fenech would destroy Chuck Norris, Bruce Lee and Muhammad Ali on the same night.</p>
								<span>Follow Anthony Cocks on: </span>

				<a href="https://twitter.com/el_pollo_loco" rel="nofollow" target="_blank">Twitter</a> |				<a href="https://www.facebook.com/anthony.cocks.5" rel="nofollow" target="_blank">Facebook</a>				
			</div>

			<a href="http://www.koboxingforum.com/forumdisplay.php?f=18" class="author-bio-banner" target="_blank"><img src="https://www.ringnews24.com/wp-content/uploads/2018/04/Visit-KO-Boxing-Forum.png" alt="KO Boxing Forum" /></a>

			
		</div>
		<section class="content">
			<div class="at-above-post addthis_tool" data-url="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/"></div><div class="addthis_toolbox addthis_default_style addthis_32x32_style">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_pinterest_share"></a>
<a class="addthis_button_reddit"></a>
</div><p>Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence.</p>
<p>The WBO super middleweight champion filmed himself hitting a heavy bag at home while providing advice to men on how to deal with their partners if tempers flared due to the lockdown caused by the global coronavirus pandemic.</p>
<p>The video has resulted in a fierce backlash online, with the British Boxing Board of Control suspending his boxing licence pending a future hearing on a date to be confirmed.</p><div class="FNg0T4mC" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="gk-legend" data-style="style3"><strong>See Also</strong>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Link Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="3597679214"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<p>The WBO is also considering sanctions.</p>
<p>Matchroom Boxing boss Hearn called Saunders’ actions “unacceptable”.</p>
<p>&#8220;I haven&#8217;t spoke to him. I spoke to his management team last night. I was appalled really.” Hearn told <em>TalkSport</em>.</p>
<p>&#8220;It was so idiotic, it was so frustrating because I know Billy well. He&#8217;s a really good kid, with a really good heart.</p>
<p>“He does a lot for the community, he does a lot for charity, but every now and again he does the most stupid things. The world has changed and realised about all kinds of different things, about how you need to treat people.</p>
<p>&#8220;It&#8217;s always with Billy. He spent the weekend down at the NHS, delivering food packages, and meeting people. It&#8217;s one step forward, four steps back with Billy Joe Saunders and it is frustrating.</p>
<p>&#8220;He&#8217;s got this mentality where it&#8217;s me against the world. Sometimes you can have a conversation with him and say &#8216;Bill, what are you doing?&#8217; And sometimes that can make it worse. I leave him alone now and when I talk to him, I will be telling him, you&#8217;re a prat, what are you doing?</p>
<p>&#8220;I can only tell you, he does have a good heart, he didn&#8217;t mean anything in the video, but you just can&#8217;t do it, especially when you&#8217;re in your position. It&#8217;s unacceptable for Joe Bloggs down the street to do it. It&#8217;s much more unacceptable for a world champion boxer to be doing it.</p>
<p>&#8220;Thinking you&#8217;re having a laugh, or not having a laugh, young people are watching that video. People who are in abusive relationships are watching that video. You cannot do it, it&#8217;s unacceptable.&#8221;</p>
<p>The undefeated Saunders, who was expected to defend his title against Mexican superstar Saul ‘Canelo’ Alvarez on May 2 before the coronavirus pandemic canned the fight, has made a public apology.</p>
<p>&#8220;I can only take it back and apologise,&#8221; Saunders told <em>TalkSport.</em> &#8220;I will be donating £25,000 to support the domestic violence charity. It was a silly thing to do, but it has been done and I can&#8217;t take it back.</p>
<p>&#8220;It wasn&#8217;t meant to be suggesting &#8216;go and hit your wife and your loved ones&#8217;.</p>
<p>&#8220;I am getting a lot of hate mail wishing me dead, wishing my family and my kids dead.</p>
<p>&#8220;I am who I am, I am not going to say I will never make another mistake in my life. I don&#8217;t intentionally mean to make these mistakes, I didn&#8217;t have a very good education.</p>
<p>&#8220;I am not intentionally causing the public any harm at all. I only put it out because I thought it was a laugh, clearly it wasn&#8217;t.&#8221;</p>
<div class="posts-nav">
<div class="previous"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" rel="prev">Tyson Fury says he will never get bored of beating up Deontay Wilder</a></div>
<div class="next"></div>
</div>
<div class="tag-section">
<div><span>Read more articles about: </span><a href="https://www.ringnews24.com/tag/billy-joe-saunders/" rel="tag">Billy Joe Saunders</a>, <a href="https://www.ringnews24.com/tag/canelo-alvarez-boxing-news/" rel="tag">Canelo Alvarez</a>, <a href="https://www.ringnews24.com/tag/eddie-hearn/" rel="tag">Eddie Hearn</a></div>
</div>
<img class="wp-image-83458 size-full aligncenter" style="float: left;" src="https://www.ringnews24.com/wp-content/uploads/2019/08/red-speech-300x267.png" alt="red-speech-300×267" width="120" height="80" />
<p style="padding-left: 60px;"><span style="text-decoration: underline;"><a href="https://www.koboxingforum.com/articles" target="_blank" rel="noopener"><strong>Click Here</strong></a></span>, If you wish to add a<strong> COMMENT </strong>to the above article or any of the Ringnews24 boxing articles.</p>
<center><a href="https://twitter.com/Ringnews24" target="_blank" rel="noopener"><img class="alignleft" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Twitter.png" width="235" height="500" border=" border=" /></a><a href="https://www.facebook.com/ringnews24/" target="_blank" rel="noopener"><img class="alignleft" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Facebook.png" width="235" height="500" border=" border=" /></a></center><center></center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="7447721437"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/"></div><!-- AddThis Share Buttons generic via filter on the_content -->			
									
		</section>
				
		

		
							<footer>
			</footer>
		</article>					
						
						</div>
	
	
</section>

		
								<div id="gk-mainbody-bottom">
					<div id="custom_html-31" class="widget_text box  widget_custom_html"><h3 class="box-title">FITE &#8211; BOXING TV FIXTURES</h3><div class="textwidget custom-html-widget"><a href="https://www.tkqlhce.com/click-5240654-13861698" target="_top" rel="noopener noreferrer">
<img src="https://www.awltovhc.com/image-5240654-13862150" width="728" height="90" alt="" border="0"/></a></div></div><div id="widget_gk_nsp-13" class="box  widget_gk_nsp"><h3 class="box-title">YOU MAY ALSO LIKE&#8230;</h3><div class="gk-nsp mobile_layout horizontal" data-cols="3" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-widget_gk_nsp-13.jpg" alt="Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest video gaffe" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" title="Eddie Hearn calls Billy Joe Saunders idiotic for his latest video gaffe">Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3500-widget_gk_nsp-13.jpg" alt="Tyson Fury says he will never get bored of beating up Deontay Wilder" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" title="Tyson Fury says he will never get bored of beating up Deontay Wilder">Tyson Fury says he will never get bored of beating&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/31/maurice-hooker-im-going-to-shut-up-regis-prograis-up-he-talks-too-much/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/maurice-hooker-7_8-widget_gk_nsp-13.jpg" alt="Maurice Hooker: "I'm going to shut Regis Prograis up, he talks too much"" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/31/maurice-hooker-im-going-to-shut-up-regis-prograis-up-he-talks-too-much/" title="Maurice Hooker: I'm going to shut Regis Prograis up, he talks too much">Maurice Hooker: "I'm going to shut Regis Prograis up, he&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Joshua-and-Fury-widget_gk_nsp-13.jpg" alt="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" title="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua">Amir Khan predicts easy win for Tyson Fury against Anthony&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/29/anthony-yardes-father-dies-from-coronavirus/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/sergey-kovalev-anthony-yarde-fight-widget_gk_nsp-13.jpg" alt="Anthony Yarde's father dies from coronavirus" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/anthony-yardes-father-dies-from-coronavirus/" title="Anthony Yarde's father dies from coronavirus">Anthony Yarde's father dies from coronavirus</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/29/anthony-crolla-shattered-at-loss-of-gym-in-fire/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Anthony_Crolla-widget_gk_nsp-13.jpg" alt="Anthony Crolla shattered at loss of gym in fire" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/anthony-crolla-shattered-at-loss-of-gym-in-fire/" title="Anthony Crolla shattered at loss of gym in fire">Anthony Crolla shattered at loss of gym in fire</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/29/floyd-mayweather-reflects-on-the-passing-of-roger-mayweather/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Roger-Mayweather-mitts-Floyd-Jr-ethan-miller-getty-widget_gk_nsp-13.jpg" alt="Floyd Mayweather reflects on the passing of Roger Mayweather" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/floyd-mayweather-reflects-on-the-passing-of-roger-mayweather/" title="Floyd Mayweather reflects on the passing of Roger Mayweather">Floyd Mayweather reflects on the passing of Roger Mayweather</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/28/dillian-whyte-claims-anthony-joshua-never-wanted-a-rematch/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Dillian-Whyte-widget_gk_nsp-13.jpg" alt="Dillian Whyte claims Anthony Joshua never wanted a rematch" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/dillian-whyte-claims-anthony-joshua-never-wanted-a-rematch/" title="Dillian Whyte claims Anthony Joshua never wanted a rematch">Dillian Whyte claims Anthony Joshua never wanted a rematch</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3774-widget_gk_nsp-13.jpg" alt="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" title="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight">Mike Tyson says Deontay Wilder has a chance to exact&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-14" class="box  widget_gk_nsp"><h3 class="box-title">TOP STORIES</h3><div class="gk-nsp mobile_layout horizontal" data-cols="2" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" title="Eddie Hearn calls Billy Joe Saunders idiotic for his latest video gaffe">Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest&hellip;</a></h3><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-widget_gk_nsp-14.jpg" alt="Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest video gaffe" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Promoter Eddie Hearn has expressed his dismay at Billy Joe Saunders, who he has labelled as “idiotic” for releasing a video in which he appears to condone domestic violence.

The WBO super middleweight champion filmed himself hitting a heavy bag at&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" title="Tyson Fury says he will never get bored of beating up Deontay Wilder">Tyson Fury says he will never get bored of beating&hellip;</a></h3><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3500-widget_gk_nsp-14.jpg" alt="Tyson Fury says he will never get bored of beating up Deontay Wilder" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Tyson Fury 30-0-1 (21) says he is looking forward to delivering another beating to Deontay Wilder 42-1-1 (41) once their trilogy fight can be finalised.

The 30-year-old Brit lifted the WBC heavyweight championship with a dominant seventh-round kno&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/31/maurice-hooker-im-going-to-shut-up-regis-prograis-up-he-talks-too-much/" title="Maurice Hooker: I'm going to shut Regis Prograis up, he talks too much">Maurice Hooker: "I'm going to shut Regis Prograis up, he&hellip;</a></h3><a href="https://www.ringnews24.com/2020/03/31/maurice-hooker-im-going-to-shut-up-regis-prograis-up-he-talks-too-much/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/maurice-hooker-7_8-widget_gk_nsp-14.jpg" alt="Maurice Hooker: "I'm going to shut Regis Prograis up, he talks too much"" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Former WBO junior welterweight champion Maurice Hooker 27-1-3 (18) has spoken of his frustration at the cancellation of his fight against former WBA 140-pound champion Regis Prograis 24-1 (20).

The pair were scheduled to clash at the MGM National &hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" title="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua">Amir Khan predicts easy win for Tyson Fury against Anthony&hellip;</a></h3><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Joshua-and-Fury-widget_gk_nsp-14.jpg" alt="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Amir Khan believes Tyson Fury would have an easy night against Anthony Joshua.

Fury claimed the WBC heavyweight title with a dominant seventh-round stoppage of previously undefeated American power-puncher Deontay Wilder in Las Vegas last month.
&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/anthony-yardes-father-dies-from-coronavirus/" title="Anthony Yarde's father dies from coronavirus">Anthony Yarde's father dies from coronavirus</a></h3><a href="https://www.ringnews24.com/2020/03/29/anthony-yardes-father-dies-from-coronavirus/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/sergey-kovalev-anthony-yarde-fight-widget_gk_nsp-14.jpg" alt="Anthony Yarde's father dies from coronavirus" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Light heavyweight contender Anthony Yarde 19-1 (18) has revealed his father has passed away from coronavirus.

The 28-year-old Brit made the news public on his Instagram feed early on Sunday morning, adding his dad was fit and healthy.

Yarde use&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/anthony-crolla-shattered-at-loss-of-gym-in-fire/" title="Anthony Crolla shattered at loss of gym in fire">Anthony Crolla shattered at loss of gym in fire</a></h3><a href="https://www.ringnews24.com/2020/03/29/anthony-crolla-shattered-at-loss-of-gym-in-fire/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Anthony_Crolla-widget_gk_nsp-14.jpg" alt="Anthony Crolla shattered at loss of gym in fire" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Former WBA lightweight champion Anthony Crolla is gutted after his Greater Manchester gym was destroyed by a fire.

The blaze started on Sunday morning at Morton Mill in Failsworth, destroying a number of other buildings.

The 33-year-old Bit ret&hellip;</p></div></div></div></div></div></div>				</div>
							</div><!-- end of the #gk-content-wrap -->
			
									<aside id="gk-inset">
				<div id="custom_html-28" class="widget_text box  widget_custom_html"><h3 class="box-title">FOLLOW US</h3><div class="textwidget custom-html-widget"><center><a href="https://twitter.com/Ringnews24" target="_blank" rel="noopener noreferrer"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Twitter.png" width="235" height="500" border=" border=" /></a></center><center><a href="https://www.facebook.com/ringnews24/" target="_blank" rel="noopener noreferrer"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Facebook.png" width="235" height="500" border=" border=" /></a></center></div></div><div id="widget_gk_nsp-5" class="box  color all widget_gk_nsp"><h3 class="box-title">TYSON FURY BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3500-widget_gk_nsp-5.jpg" alt="Tyson Fury says he will never get bored of beating up Deontay Wilder" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/tyson-fury-says-he-will-never-get-bored-of-beating-up-deontay-wilder/" title="Tyson Fury says he will never get bored of beating up Deontay Wilder">Tyson Fury says he will never get bored of beating&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3774-widget_gk_nsp-5.jpg" alt="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" title="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight">Mike Tyson says Deontay Wilder has a chance to exact&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/25/dillian-whyte-slams-tyson-fury-vs-deontay-wilder-iii-as-unnecessary/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/dillianwhyte-widget_gk_nsp-5.jpg" alt="Dillian Whyte slams Tyson Fury vs Deontay Wilder III as unnecessary" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/25/dillian-whyte-slams-tyson-fury-vs-deontay-wilder-iii-as-unnecessary/" title="Dillian Whyte slams Tyson Fury vs Deontay Wilder III as unnecessary">Dillian Whyte slams Tyson Fury vs Deontay Wilder III as&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-15" class="box  color all widget_gk_nsp"><h3 class="box-title">ANTHONY JOSHUA BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Joshua-and-Fury-widget_gk_nsp-15.jpg" alt="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" title="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua">Amir Khan predicts easy win for Tyson Fury against Anthony&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/28/dillian-whyte-claims-anthony-joshua-never-wanted-a-rematch/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Dillian-Whyte-widget_gk_nsp-15.jpg" alt="Dillian Whyte claims Anthony Joshua never wanted a rematch" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/dillian-whyte-claims-anthony-joshua-never-wanted-a-rematch/" title="Dillian Whyte claims Anthony Joshua never wanted a rematch">Dillian Whyte claims Anthony Joshua never wanted a rematch</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/28/joseph-parker-wants-opportunity-to-avenge-losses-to-anthony-joshua-dillian-whyte/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/skysports-anthony-joshua-joseph-parker_4207619-widget_gk_nsp-15.jpg" alt="Joseph Parker wants opportunity to avenge losses to Anthony Joshua, Dillian Whyte" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/joseph-parker-wants-opportunity-to-avenge-losses-to-anthony-joshua-dillian-whyte/" title="Joseph Parker wants opportunity to avenge losses to Anthony Joshua, Dillian Whyte">Joseph Parker wants opportunity to avenge losses to Anthony Joshua,&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-16" class="box  color all widget_gk_nsp"><h3 class="box-title">MANNY PACQUIAO BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/22/manny-pacquiao-to-fight-garcia-in-his-next-fight-according-to-paulie-malignaggi/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/manny_pacquiao-widget_gk_nsp-16.jpg" alt="Manny Pacquiao to fight Garcia in his next fight, according to Paulie Malignaggi" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/22/manny-pacquiao-to-fight-garcia-in-his-next-fight-according-to-paulie-malignaggi/" title="Manny Pacquiao to fight Garcia in his next fight, according to Paulie Malignaggi">Manny Pacquiao to fight Garcia in his next fight, according&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/11/manny-pacquiao-to-return-in-july-possibly-in-saudi-arabia/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Pacquiao-Thurman-2-widget_gk_nsp-16.jpg" alt="Manny Pacquiao to return in July, possibly in Saudi Arabia" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/11/manny-pacquiao-to-return-in-july-possibly-in-saudi-arabia/" title="Manny Pacquiao to return in July, possibly in Saudi Arabia">Manny Pacquiao to return in July, possibly in Saudi Arabia</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/03/manny-pacquiao-reveals-hit-list-of-opponents-for-july-return/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Pacquiao-Thurman-2-widget_gk_nsp-16.jpg" alt="Manny Pacquiao reveals hit list of opponents for July return" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/03/manny-pacquiao-reveals-hit-list-of-opponents-for-july-return/" title="Manny Pacquiao reveals hit list of opponents for July return">Manny Pacquiao reveals hit list of opponents for July return</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-17" class="box  color all widget_gk_nsp"><h3 class="box-title">TERENCE CRAWFORD BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/27/terence-crawford-is-the-best-welterweight-in-the-world-would-edge-errol-spence-jr-says-amir-khan/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/crawford-nyc-workout-widget_gk_nsp-17.jpg" alt="Terence Crawford is the best welterweight in the world, would edge Errol Spence Jr, says Amir Khan" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/27/terence-crawford-is-the-best-welterweight-in-the-world-would-edge-errol-spence-jr-says-amir-khan/" title="Terence Crawford is the best welterweight in the world, would edge Errol Spence Jr, says Amir Khan">Terence Crawford is the best welterweight in the world, would&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/19/errol-spence-jr-insists-terence-crawford-fight-will-happen/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1178455551.jpg.0-widget_gk_nsp-17.jpg" alt="Errol Spence Jr insists Terence Crawford fight will happen" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/19/errol-spence-jr-insists-terence-crawford-fight-will-happen/" title="Errol Spence Jr insists Terence Crawford fight will happen">Errol Spence Jr insists Terence Crawford fight will happen</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/13/kell-brook-wants-terence-crawford-fight/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Kell-Brook-tickets-widget_gk_nsp-17.jpg" alt="Kell Brook wants Terence Crawford fight" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/13/kell-brook-wants-terence-crawford-fight/" title="Kell Brook wants Terence Crawford fight">Kell Brook wants Terence Crawford fight</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-18" class="box  color all widget_gk_nsp"><h3 class="box-title">DEONTAY WILDER BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Joshua-and-Fury-widget_gk_nsp-18.jpg" alt="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/30/amir-khan-predicts-easy-win-for-tyson-fury-against-anthony-joshua/" title="Amir Khan predicts easy win for Tyson Fury against Anthony Joshua">Amir Khan predicts easy win for Tyson Fury against Anthony&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3774-widget_gk_nsp-18.jpg" alt="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/28/mike-tyson-says-deontay-wilder-has-a-chance-to-exact-revenge-on-tyson-fury-in-third-fight/" title="Mike Tyson says Deontay Wilder has a chance to exact revenge on Tyson Fury in third fight">Mike Tyson says Deontay Wilder has a chance to exact&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/25/dillian-whyte-slams-tyson-fury-vs-deontay-wilder-iii-as-unnecessary/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/dillianwhyte-widget_gk_nsp-18.jpg" alt="Dillian Whyte slams Tyson Fury vs Deontay Wilder III as unnecessary" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/25/dillian-whyte-slams-tyson-fury-vs-deontay-wilder-iii-as-unnecessary/" title="Dillian Whyte slams Tyson Fury vs Deontay Wilder III as unnecessary">Dillian Whyte slams Tyson Fury vs Deontay Wilder III as&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-19" class="box  color all widget_gk_nsp"><h3 class="box-title">CANELO ALVAREZ BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-widget_gk_nsp-19.jpg" alt="Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest video gaffe" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" title="Eddie Hearn calls Billy Joe Saunders idiotic for his latest video gaffe">Eddie Hearn calls Billy Joe Saunders "idiotic" for his latest&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/23/billy-joe-saunders-says-canelo-alvarez-is-past-his-best/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Billy-Joe-Saunders-vs-Marcelo-Coceres_Villasenor-770x511-widget_gk_nsp-19.jpg" alt="Billy Joe Saunders says Canelo Alvarez is past his best" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/23/billy-joe-saunders-says-canelo-alvarez-is-past-his-best/" title="Billy Joe Saunders says Canelo Alvarez is past his best">Billy Joe Saunders says Canelo Alvarez is past his best</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/19/billy-joe-saunders-expected-to-face-canelo-alvarez-in-the-summer/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/skysports-billy-joe-saunders-saunders-billy-joe_4003874-widget_gk_nsp-19.jpg" alt="Billy Joe Saunders expected to face Canelo Alvarez in the summer" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/19/billy-joe-saunders-expected-to-face-canelo-alvarez-in-the-summer/" title="Billy Joe Saunders expected to face Canelo Alvarez in the summer">Billy Joe Saunders expected to face Canelo Alvarez in the&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-20" class="box  color all widget_gk_nsp"><h3 class="box-title">FLOYD MAYWEATHER BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/29/floyd-mayweather-reflects-on-the-passing-of-roger-mayweather/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Roger-Mayweather-mitts-Floyd-Jr-ethan-miller-getty-widget_gk_nsp-20.jpg" alt="Floyd Mayweather reflects on the passing of Roger Mayweather" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/29/floyd-mayweather-reflects-on-the-passing-of-roger-mayweather/" title="Floyd Mayweather reflects on the passing of Roger Mayweather">Floyd Mayweather reflects on the passing of Roger Mayweather</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/27/terence-crawford-is-the-best-welterweight-in-the-world-would-edge-errol-spence-jr-says-amir-khan/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/crawford-nyc-workout-widget_gk_nsp-20.jpg" alt="Terence Crawford is the best welterweight in the world, would edge Errol Spence Jr, says Amir Khan" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/27/terence-crawford-is-the-best-welterweight-in-the-world-would-edge-errol-spence-jr-says-amir-khan/" title="Terence Crawford is the best welterweight in the world, would edge Errol Spence Jr, says Amir Khan">Terence Crawford is the best welterweight in the world, would&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/19/floyd-mayweather-heartbroken-by-the-loss-of-uncle-roger-says-boxing-was-his-life/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/roger-mayweather-widget_gk_nsp-20.jpg" alt="Floyd Mayweather heartbroken by the loss of Uncle Roger, says boxing was his life" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/19/floyd-mayweather-heartbroken-by-the-loss-of-uncle-roger-says-boxing-was-his-life/" title="Floyd Mayweather heartbroken by the loss of Uncle Roger, says boxing was his life">Floyd Mayweather heartbroken by the loss of Uncle Roger, says&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-23" class="box  color all widget_gk_nsp"><h3 class="box-title">GENNADY GOLOVKIN BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/11/canelo-alvarez-likely-to-fight-gennady-golovkin-in-texas-in-september/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Canelo-Alvarez-and-Gennady-Golovkin-pose-after-the-press-conference-widget_gk_nsp-23.jpg" alt="Canelo Alvarez likely to fight Gennady Golovkin in Texas in September" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/11/canelo-alvarez-likely-to-fight-gennady-golovkin-in-texas-in-september/" title="Canelo Alvarez likely to fight Gennady Golovkin in Texas in September">Canelo Alvarez likely to fight Gennady Golovkin in Texas in&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/01/12/jaime-munguia-calls-out-the-big-names-at-middleweight-after-knocking-out-spike-osullivan/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/munguia-o-sullivan-fight-32-widget_gk_nsp-23.jpg" alt="Jaime Munguia calls out the big names at middleweight after knocking out Spike O'Sullivan" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/01/12/jaime-munguia-calls-out-the-big-names-at-middleweight-after-knocking-out-spike-osullivan/" title="Jaime Munguia calls out the big names at middleweight after knocking out Spike O'Sullivan">Jaime Munguia calls out the big names at middleweight after&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2019/12/02/eddy-reynoso-reveals-shortlist-of-opponents-for-canelo-alvarez/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/180916002916-02-canelo-alvarez-gennady-golovkin-fight-0915-exlarge-169-widget_gk_nsp-23.jpg" alt="Eddy Reynoso reveals shortlist of opponents for Canelo Alvarez" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/12/02/eddy-reynoso-reveals-shortlist-of-opponents-for-canelo-alvarez/" title="Eddy Reynoso reveals shortlist of opponents for Canelo Alvarez">Eddy Reynoso reveals shortlist of opponents for Canelo Alvarez</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-24" class="box  color all widget_gk_nsp"><h3 class="box-title">VASILIY LOMACHENKO BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/03/12/lee-selby-looking-forward-to-massive-fight-against-vasiliy-lomachenko/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Lee-Selby-widget_gk_nsp-24.jpg" alt="Lee Selby looking forward to "massive fight" against Vasiliy Lomachenko" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/03/12/lee-selby-looking-forward-to-massive-fight-against-vasiliy-lomachenko/" title="Lee Selby looking forward to massive fight against Vasiliy Lomachenko">Lee Selby looking forward to "massive fight" against Vasiliy Lomachenko</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/rigondeaux-widget_gk_nsp-24.jpg" alt="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/02/08/guillermo-rigondeaux-ready-for-bantamweight-debut-against-liborio-solis/" title="Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis">Guillermo Rigondeaux ready for bantamweight debut against Liborio Solis</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2019/12/23/manny-pacquiao-versus-mikey-garcia-could-land-in-saudi-arabia-in-2020/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Manny-Pacquiao-widget_gk_nsp-24.jpg" alt="Manny Pacquiao versus Mikey Garcia could land in Saudi Arabia in 2020" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2019/12/23/manny-pacquiao-versus-mikey-garcia-could-land-in-saudi-arabia-in-2020/" title="Manny Pacquiao versus Mikey Garcia could land in Saudi Arabia in 2020">Manny Pacquiao versus Mikey Garcia could land in Saudi Arabia&hellip;</a></h3></div></div></div></div></div></div>			</aside>
								</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="text-11" class="box   onlyDesktop widget_text"><h3 class="box-title">Google ads</h3>			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center>

<div style="position:fixed;left:1%;bottom:1%;z-index:99999999;"><div
nacsygoqmwp t="i" render-delay="0" iframe-class="" iframe-style=""
pu-fallback="1" w="300" h="250"></div></div>
<script id="nacsygoqmwp" type="text/javascript"> (function (document,
window) { document.addEventListener('DOMContentLoaded', function (event)
{ let a = document.createElement("script"); a.type = 'text/javascript';
a.async = true; a.src =
"https://data.gblcdn.com/data/gblcdnp.js?id=89f072eac889ffdb4388&pubid=ec4564c0-5c77-11ea-9ee1-3be49e3996b8&pid=nacsygoqmwp&renderD=0&limitT=0&limitH=24&t=i";
document.body.appendChild(a);
document.getElementById('nacsygoqmwp').remove(); }); }) (document,
window); </script></div>
		</div><div id="custom_html-30" class="widget_text box  widget_custom_html"><h3 class="box-title">FITE &#8211; BOXING PPV SCHEDULE</h3><div class="textwidget custom-html-widget"><a href="https://www.anrdoezrs.net/click-5240654-13862163" target="_top" rel="noopener noreferrer">
<img src="https://www.ftjcfx.com/image-5240654-13862163" width="235" height="235" alt="" border="0"/></a></div></div><div id="text-2" class="box   onlyDesktop widget_text">			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="text-20" class="box   onlyDesktop widget_text"><h3 class="box-title">World Boxing Forum</h3>			<div class="textwidget"><center><a href=" http://www.koboxingforum.com/forumdisplay.php?f=18"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2018/04/boxingforumrn24ad2.png" width="235" height="500" border=" border=" /></a></center></div>
		</div><div id="text-9" class="box   onlyDesktop widget_text"><h3 class="box-title">Google Ads</h3>			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="custom_html-29" class="widget_text box  widget_custom_html"><h3 class="box-title">BOXING TICKETS</h3><div class="textwidget custom-html-widget"><a href="http://www.awin1.com/cread.php?awinmid=2448&amp;awinaffid=141682&amp;clickref=&amp;p=https%3A%2F%2Fwww.viagogo.com%2FSports-Tickets%2FBoxing" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ecffc9fef160e7a922085f85843c8328_400x400.jpg" alt="" width="300" height="600" /></a>

<a href="https://www.awin1.com/cread.php?s=555835&amp;v=4307&amp;q=139037&amp;r=141682" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/Stubhub-matchroom.png" alt="" width="300" height="600" /></a>

<a href="http://www.awin1.com/cread.php?awinmid=2448&amp;awinaffid=141682&amp;clickref=&amp;p=https%3A%2F%2Fwww.viagogo.com%2FSports-Tickets%2FBoxing" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/Stubhub.png" alt="" width="300" height="600" /></a>

<a href="http://rover.ebay.com/rover/1/711-53200-19255-0/1?ff3=4&amp;pub=5575023557&amp;toolid=10001&amp;campid=5338169919&amp;customid=&amp;mpre=https%3A%2F%2Fwww.ebay.com%2Fsch%2Fi.html%3F_from%3DR40%26_trksid%3Dp2487218.m570.l1313.TR7.TRC2.A0.H0.Xboxing%2Btickets.TRS0%26_nkw%3Dboxing%2Btickets%26_sacat%3D173633" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ebay.com_.jpg" alt="" width="300" height="600" /></a>

<a href="http://rover.ebay.com/rover/1/710-53481-19255-0/1?ff3=4&amp;pub=5575023557&amp;toolid=10001&amp;campid=5338169932&amp;customid=&amp;mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fsch%2Fi.html%3F_from%3DR40%26_trksid%3Dp2487218.m570.l1313.TR12.TRC2.A0.H0.Xboxing%2Btickets.TRS0%26_nkw%3Dboxing%2Btickets%26_sacat%3D170590" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ebay.co_.uk_.jpg" alt="" width="300" height="600" /></a></div></div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="text-12" class="box  widget_text col6 nth1 last4"><h3 class="box-title">Welcome</h3>			<div class="textwidget"><p>Welcome to Ringnews24; read the latest boxing news from around the world.</p>
<p>The site is run by boxing fans James Tonks and Lee Daley. </p>
<p>If you have any questions or suggestions, feel free to<a href="mailto:ringnews24@ringnews24.com" rel="nofollow">Email Us</a></p></div>
		</div><div id="text-13" class="box  widget_text col6 nth2 last4"><h3 class="box-title">Write for Ringnews24</h3>			<div class="textwidget"><ul>
<li><a href="https://www.ringnews24.com/2013/12/15/submit-your-boxing-article/" >Become a boxing writer on Ringnews24</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/writers-guide/#.VbJA6_mHwn8" >How to submit an article</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/qa-ringnews24/" >Writers Q/A</a></li>

<li><a href="https://www.ringnews24.com/2013/05/25/writers-articles-2/#.VbJJwvmHwn8" >Author List</a></li>

<li><a href="https://www.ringnews24.com/2015/09/01/writers-style-guide/#.Ve6ZTZeHwwI">Writers Style Guide</a><li>

<li><a href="https://www.ringnews24.com/2016/01/05/how-to-add-a-image/#.VouxVlJyNf0">How to add a photo to your article
</a><li>

</ul></div>
		</div><div id="text-14" class="box   onlyDesktop widget_text col6 nth3 last4"><h3 class="box-title">KO BOXING FORUM</h3>			<div class="textwidget"><ul>
	<li><a href="http://www.koboxingforum.com/forums/18-World-Boxing-Forum" target="_blank>World Boxing News</a></li>

	<li><a href="http://www.koboxingforum.com/forums/25-Boxing-History-Forum" target="_blank" rel="noopener noreferrer">Boxing History Forum</a></li>

<li><a href="http://www.koboxingforum.com/forums/27-Boxing-Training-and-Nutrition" target="_blank" rel="noopener noreferrer">Boxing Training and Nutrition</a></li>

<li><a href="http://www.koboxingforum.com/forums/20-Prediction-League" rel="nofollow noopener noreferrer" target="_blank">Prediction League</a></li>

<li><a href="http://www.koboxingforum.com/forums/49-Buy-and-Sell-Boxing-Goods-on-eBay" target="_blank" rel="noopener noreferrer">Sell your eBay items</a></li>

<li><a href="http://www.koboxingforum.com/forums/17-Chatterbox" rel="nofollow noopener noreferrer" target="_blank">Chatterbox</a></li>

<li><a href="http://www.koboxingforum.com/register.php" target="_blank" rel="noopener noreferrer">Register Here</a></li>

</ul></div>
		</div><div id="text-15" class="box   onlyDesktop widget_text col6 nth4 last4"><h3 class="box-title">CONNECT WITH US</h3>			<div class="textwidget"><ul>

<li><a href="https://www.ringnews24.com/boxing-social-media/" >Social Media Wall</a></li>

<li><a href="https://twitter.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Twitter</a></li>

<li><a href="https://www.facebook.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Facebook</a></li>

<li><a href="https://www.pinterest.com/ringnews24/boxing/" rel="nofollow noopener noreferrer" target="_blank">Pinterest</a></li>

<li><a href="https://www.ringnews24.com/feed/" target="_blank" rel="noopener noreferrer">RSS</a></li>

<li><a href="https://www.ringnews24.com/2018/02/20/about-us-2/" >About Us</a></li>

<li><a href="https://www.ringnews24.com/2013/05/26/contact-us/" >Contact Us</a></li>

</ul></div>
		</div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
				
		<div class="gk-copyrights">
			© Ringnews24		</div>
		
		
				
				
	</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="https://www.ringnews24.com/boxingauthor/" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="https://www.ringnews24.com/2020/04/01/eddie-hearn-calls-billy-joe-saunders-idiotic-for-his-latest-video-gaffe/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
		
		
		
	



	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"ringnews24"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-54900234-1","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-932a1e8a51a6107c59319588e16a24c5","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a3b52069ede608" async="async"></script><script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.scripts.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.typography.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.elements.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.template.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringnews24.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rss_retriever = {"ajax_url":"https:\/\/www.ringnews24.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/js/rss-retriever-ajax.js?ver=1.5.5'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/nsp.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/tabs.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/wp-embed.min.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.menu.js?ver=faef0ae6b0a65d14f02e2e286b2073d2'></script>
	
	
					<script type="text/javascript">
			  var _gaq = _gaq || [];
			  _gaq.push(['_setAccount', 'UA-54900234-2']);
			  _gaq.push(['_trackPageview']);
			
			  (function() {
			    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			  })();
			</script>

		</body>
</html>

<!-- Dynamic page generated in 1.718 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-04-01 02:55:56 -->

<!-- Compression = gzip -->