<!DOCTYPE html>
<html lang="en-GB" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head>
	<title>Terence Crawford primed for Kell Brook battle on Saturday night - Boxing News - Ring News24</title>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<meta name="og:title" content="Terence Crawford primed for Kell Brook battle on Saturday night" />
<meta name="og:image" content="https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain.jpg" />
<meta name="og:type" content="article" />
<meta name="og:description" content="WBO welterweight champion Terence ‘Bud’ Crawford 36-0 (27) says he doesn’t know how to rate Kell Brook 39-2 (27) because he has never been in the ring with him.

The 33-year-old southpaw from " />
<meta name="og:url" content="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" />
	
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="shortcut icon" href="/favicon.ico" />
	<link rel="pingback" href="https://www.ringnews24.com/xmlrpc.php" />
		<!--[if IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie9.css" />
	<![endif]-->
	<!--[if lt IE 9]>
	<link rel="stylesheet" href="https://www.ringnews24.com/wp-content/themes/News/css/ie8.css" />
	<![endif]-->
	
		
	<!--[if lt IE 9]>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/html5shiv.js"></script>
<script src="https://www.ringnews24.com/wp-content/themes/News/js/respond.js"></script>
<![endif]-->
	
			  
	
<style type="text/css">
	.gk-page { max-width: 1250px; }
		#gk-mainbody-columns > aside { width: 22%;}
	#gk-mainbody-columns > section { width: 78%; }
	#gk-mainbody-columns { background-position: 78% 0!important; }
		
		#gk-inset { width: 27%;}
	#gk-content-wrap { width: 73%; }
	#gk-mainbody-columns > section { background-position: 73% 0!important; }
		
		#gk-mainbody > div { width: 100%; }
		
</style>

	
		
			
	
		<script type="text/javascript">
		var thickboxL10n = {
			"next":"Next >",
			"prev":"< Prev",
			"image":"Image",
			"of":"of",
			"close":"Close",
			"noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.",
			"loadingAnimation":"https://www.ringnews24.com/wp-includes/js/thickbox/loadingAnimation.gif",
			"closeImage":"https://www.ringnews24.com/wp-includes/js/thickbox/tb-close.png"
		};
	</script>

		<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ring News 24 &raquo; Feed" href="https://www.ringnews24.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ring News 24 &raquo; Comments Feed" href="https://www.ringnews24.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringnews24.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4478bc98c011648881d6f6881ca2a7b5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gavern-normalize-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/normalize.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/template.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wp-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-stuff-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/stuff.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-wpextensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/wp.extensions.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-extensions-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/extensions.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-typography-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.typography.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-elements-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.elements.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-shortcodes-template-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/shortcodes.template.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-desktop-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/desktop.small.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='(max-width: 1230px)' />
<link rel='stylesheet' id='gavern-tablet-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='(max-width: 1030px)' />
<link rel='stylesheet' id='gavern-tablet-small-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/tablet.small.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='(max-width: 820px)' />
<link rel='stylesheet' id='gavern-mobile-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/mobile.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='(max-width: 580px)' />
<link rel='stylesheet' id='gavern-style-css'  href='https://www.ringnews24.com/wp-content/themes/News/css/style1.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='gavern-thickbox-css'  href='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.ringnews24.com/wp-includes/css/dist/block-library/style.min.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='rss-retriever-css'  href='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/css/rss-retriever.css?ver=1.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ringnews24.com/wp-content/themes/News/fonts/fontawesome/font-awesome.min.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.ringnews24.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=4478bc98c011648881d6f6881ca2a7b5' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/slideshow.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gk-news-slideshow-js'></script>
<link rel="https://api.w.org/" href="https://www.ringnews24.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ringnews24.com/wp-json/wp/v2/posts/92362" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringnews24.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringnews24.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Queensberry confirm three positive coronavirus tests' href='https://www.ringnews24.com/2020/11/11/queensberry-confirm-three-positive-coronavirus-tests/' />
<link rel='next' title='Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia' href='https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/' />
<link rel="canonical" href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" />
<link rel='shortlink' href='https://www.ringnews24.com/?p=92362' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F11%2F11%2Fterence-crawford-primed-for-kell-brook-battle-on-saturday-night%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringnews24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringnews24.com%2F2020%2F11%2F11%2Fterence-crawford-primed-for-kell-brook-battle-on-saturday-night%2F&#038;format=xml" />
<link href="https://www.ringnews24.com/?opensearch_description=1" title="Ring News 24" rel="search" type="application/opensearchdescription+xml" /><link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.ringnews24.com/wp-content/uploads/2018/03/cropped-155x100-270x270.png" />
	
	<link href="https://fonts.googleapis.com/css?family=Hammersmith+One" rel="stylesheet" type="text/css" /><style type="text/css">
body,
h1, h2, h3, h4, h5, h6,
#main-menu > li li,
.bigtitle h3.header,
.box.badge-new .box-title::after,
.box.badge-popular .box-title::after,
.box.badge-top .box-title::after,
.box.bigtitle .box-title { font-family: Arial, Helvetica, sans-serif; }

#gk-logo.text,
#main-menu > li,
#top-menu,
#gk-user-area,
.box .box-title,
.gk-tabs-nav,
.nsphover .gk-nsp-category { font-family: 'Hammersmith One'; }

</style>
	<script type="text/javascript">
           $GK_PAGE_URL = 'https://www.ringnews24.com';
           $GK_TMPL_URL = 'https://www.ringnews24.com/wp-content/themes/News';
           $GK_TMPL_NAME = 'news';
           $GK_MENU = [];
           $GK_MENU["mainmenu"] = [];
           $GK_MENU["mainmenu"]["animation"] = "width_height_opacity";
           $GK_MENU["mainmenu"]["animation_speed"] = "fast";
           $GK_MENU["topmenu"] = [];
           $GK_MENU["topmenu"]["animation"] = "none";
           $GK_MENU["topmenu"]["animation_speed"] = "normal";
           $GK_MENU["footermenu"] = [];
           $GK_MENU["footermenu"]["animation"] = "none";
           $GK_MENU["footermenu"]["animation_speed"] = "normal";
        </script>
		
		
	
		
		<link rel="stylesheet" type="text/css" href="https://www.ringnews24.com/wp-content/themes/News/css/override.css">

	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	<script>
	     (adsbygoogle = window.adsbygoogle || []).push({
	          google_ad_client: "ca-pub-5502369698975283",
	          enable_page_level_ads: true
	     });
	</script>
</head>
<body class="post-template-default single single-post postid-92362 single-format-standard" data-tablet-width="1030">
	<header id="gk-page-top">
		<div class="gk-page topbar">
						<h1>
				<a href="https://www.ringnews24.com" class="imageLogo"><img src="https://www.ringnews24.com/wp-content/uploads/2015/07/155x100.png" alt="" width="500" height="134" /></a>
			</h1>
						<div class="topad">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Homepage - Top advert 320x100 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:320px;height:100px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="2256322169"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
		</div>
		<div class="gk-page menubar">
			
			
							<ul id="main-menu" class="menu gk_normal"><li id="menu-item-42794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42794"><a href="http://www.ringnews24.com/">RN24</a></li>
<li id="menu-item-42984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42984"><a href="https://www.ringnews24.com/boxing-streaming/">Live Streaming</a></li>
<li id="menu-item-80605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80605"><a href="https://www.ringnews24.com/boxing-on-tv/">Boxing on TV Schedule</a></li>
<li id="menu-item-42805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42805"><a rel="nofollow" href="http://www.koboxingforum.com">Boxing Forum</a></li>
<li id="menu-item-64797" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-64797"><a title="Our Writers" href="https://www.ringnews24.com/2013/05/25/writers-articles-2/">Our Writers</a></li>
</ul>				<div id="main-menu-mobile" class="menu-{menu slug}-container"><select onchange="window.location.href=this.value;"><option value="#">Select a page</option><option value="http://www.ringnews24.com/"> RN24</option><option value="https://www.ringnews24.com/boxing-streaming/"> Live Streaming</option><option value="https://www.ringnews24.com/boxing-on-tv/"> Boxing on TV Schedule</option><option value="http://www.koboxingforum.com"> Boxing Forum</option><option value="https://www.ringnews24.com/2013/05/25/writers-articles-2/"> Our Writers</option></select></div>						
						<div id="gk-user-area">
								<a href="#" id="gk-login">Login</a>
								
								<a href="https://www.ringnews24.com/feed/" id="gk-rss">RSS</a>
							</div>
					</div>
	</header>


<section id="gk-content-top" class="gk-page">
	<ul id="top-menu" class="menu gk_normal"><li id="menu-item-42803" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42803"><a href="https://www.ringnews24.com/category/boxing-news-and-views/">Breaking Boxing News</a></li>
<li id="menu-item-42789" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42789"><a href="https://www.ringnews24.com/category/boxing-news/">Boxing News</a></li>
<li id="menu-item-42791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42791"><a href="https://www.ringnews24.com/category/boxing-results/">Fight Results</a></li>
<li id="menu-item-42793" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42793"><a href="https://www.ringnews24.com/category/boxing-radio/">Radio</a></li>
<li id="menu-item-42788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42788"><a href="https://www.ringnews24.com/category/boxing-history/">Boxing History</a></li>
<li id="menu-item-42790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42790"><a href="https://www.ringnews24.com/category/female-boxing-news/">Female Boxing News</a></li>
<li id="menu-item-42792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42792"><a href="https://www.ringnews24.com/category/boxing-interviews/">Boxing Interviews</a></li>
<li id="menu-item-42429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42429"><a href="http://www.koboxingforum.com/">Boxing Forum</a></li>
</ul>	
		<div id="gk-social-icons">
		<a href="https://twitter.com/ringnews24" class="gk-twitter-icon" rel="nofollow">Twitter</a><a href="https://www.facebook.com/ringnews24" class="gk-facebook-icon" rel="nofollow">Facebook</a>	</div>
		
		<div id="gk-search">
		
<form method="get" id="searchform" action="https://www.ringnews24.com/">
	<label for="s">Search</label>
	<input type="text" class="field" name="s" id="s" placeholder="Search" value="" />
	
	<input type="submit" id="searchsubmit" value="Search" />
</form>	</div>
		
	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</section>

<div class="gk-page-wrap gk-page">
	<div id="gk-mainbody-columns">			
		<section>
			<div id="gk-content-wrap">
								
								<div id="gk-top2">
					<div class="gk-page widget-area">
											</div>
					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
				<!-- Mainbody, breadcrumbs -->
								<div id="gk-breadcrumb-area">
					<nav class="gk-breadcrumbs"><a href="https://www.ringnews24.com" class="gk-home">Ring News 24</a><a href="https://www.ringnews24.com/category/boxing-news/" rel="category tag">Boxing News</a> <a href="https://www.ringnews24.com/category/boxing-news-and-views/" rel="category tag">Breaking Boxing News</a><span class="gk-current">Terence Crawford primed for Kell Brook battle on Saturday night</span></nav>					<!--[if IE 8]>
					<div class="ie8clear"></div>
					<![endif]-->
				</div>
								
							
<section id="gk-mainbody">
	<div>
					
	<article id="post-92362" class="post-92362 post type-post status-publish format-standard has-post-thumbnail hentry category-boxing-news category-boxing-news-and-views tag-kell-brook tag-terence-crawford-boxing-news no-sidebar">
				<header>
			
<h1>
			Terence Crawford primed for Kell Brook battle on Saturday night
		
	</h1>
<div class="subtitle-addons">
	<div class="author-name">
		<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>	</div>
	<div class="entry-date">
		11 November 2020	</div>
</div>

				
		</header>
		
		
		<figure class="featured-image">
		<img width="1200" height="800" src="https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain.jpg 1200w, https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-300x200.jpg 300w, https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-1024x683.jpg 1024w, https://www.ringnews24.com/wp-content/uploads/2020/11/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-768x512.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" />		
					<figcaption>Terence Crawford. Photo credit: Mikey Williams/Top Rank</figcaption>			</figure>
						
		<div class="author-wrapper">
			<div class="author">
				
				<div class="author-avatar">
					<img alt='' src='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=150&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf7072698d3c3136eab536528cc1b6a3?s=300&#038;d=mm&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' loading='lazy'/>				</div>
				<div class="author-name">
					<a href="https://www.ringnews24.com/author/anthony-cocks/" title="Posts by Anthony Cocks" rel="author">Anthony Cocks</a>				</div>
				<div class="newpost">
					<a href="http://www.ringnews24.com/2013/12/15/submit-your-boxing-article/">Write For Us</a>
				</div>
			</div>

			<div class="author-bio">
				
				<span>Anthony Cocks</span>
				<p>Australian-based boxing journalist Anthony Cocks has been covering the sport for over 15 years for various print and online publications. He refuses to believe that Roberto Duran ever lost to Tommy Hearns and says that Jeff Fenech would destroy Chuck Norris, Bruce Lee and Muhammad Ali on the same night.</p>
								<span>Follow Anthony Cocks on: </span>

				<a href="https://twitter.com/el_pollo_loco" rel="nofollow" target="_blank">Twitter</a> |				<a href="https://www.facebook.com/anthony.cocks.5" rel="nofollow" target="_blank">Facebook</a>				
			</div>

			<a href="http://www.koboxingforum.com/forumdisplay.php?f=18" class="author-bio-banner" target="_blank"><img src="https://www.ringnews24.com/wp-content/uploads/2018/04/Visit-KO-Boxing-Forum.png" alt="KO Boxing Forum" /></a>

			
		</div>
		<section class="content">
			<div class="at-above-post addthis_tool" data-url="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/"></div><div class="addthis_toolbox addthis_default_style addthis_32x32_style">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_pinterest_share"></a>
<a class="addthis_button_reddit"></a>
</div><p>WBO welterweight champion Terence ‘Bud’ Crawford 36-0 (27) says he doesn’t know how to rate Kell Brook 39-2 (27) because he has never been in the ring with him.</p>
<p>The 33-year-old southpaw from Omaha, Nebraska will make the fourth defence of his 147-pound belt against England’s Brook, 34, at ‘The Bubble’ at the MGM Grand in Las Vegas, Nevada on Saturday night.</p>
<p>“He’s not the only opponent that went into the fight thinking they were going to stop me or knock me out, so that’s nothing new for me. He’s just going to have to live up to his words,” Crawford said.</p><div class="qmACcwuN" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><div class="gk-legend" data-style="style3"><strong>See Also</strong>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Link Ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="3597679214"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<p>“I actually can’t rate him because I’ve never been in the ring with him. Actually, he was never on my radar from the jump. This was a fight that he wanted, that he kept calling for.</p>
<p>“Once the [Manny] Pacquiao fight fell through, he was the next option given the circumstances of COVID and whatnot. I must’ve been on his radar. He was never on my radar. He’s on my radar now, and we’re fighting this weekend. That’s what it is.</p>
<p>“I go about fights to get the win, no matter how they come. I’m not going out there to try and outdo previous performances or any other fighter.</p>
<p>“My thing is to go out there and make sure I get the win and secure that first and everything else can come second. If the knockout is there, of course I’m going to go out there and take it. But if it’s not, then like I said before, we’re prepared for 12 rounds.</p>
<p>“He’s never faced nobody like me. He can say I never faced nobody like him and I can say he’s never faced nobody like me. I don’t know what he brings to the table because I haven’t been there. I haven’t been in the ring with him, so we shall see come this week.”</p>
<p>Brook has promised to stop Crawford and put an end to his unbeaten run.</p>
<p>“I stop him, or he quits on the stool,” Brook said. “I’m fully focused. I’ve never been ready for a fight like this before. Looking forward to whatever Terence brings because I can match him. I’m ready for a war.</p>
<p>“I’ve been here before. I’ve been on this stage. I’ve been in there with pound-for-pound top fighters like Golovkin and Errol Spence. I took the title away from Shawn Porter in America. I know what it takes to be champion.</p>
<p>“He’s going to have a rude awakening, I’ll tell you that. He’s going to have a rude awakening Saturday night when he gets in there.</p>
<p>“I hope he’s [overlooking me]. I hope he is because I’m coming with force. Trust me.</p>
<p>“I’m in a great, great place in my mind, and my weight is fantastic for this fight. Forget the weight. The weight’s made.</p>
<p>“I think [winning this fight] would rank above Shawn Porter given everything I’ve been through, everyone writing me off. I think you gotta put it up there because this is the pound-for-pound best fighter in the world. You’ve gotta put him as number one. Nobody has done that in history from Britain, and I’m glad that all the fans will be able to see it on Premier Sports. They’re going to stay up and enjoy me become two-time world champion.</p>
<p>“My body clock has adjusted to the Vegas time now, so everything is on point. The sleeping, my body clock is there. Everything’s there that’s needed to win this fight.”</p>
<div class="posts-nav">
<div class="previous"><a href="https://www.ringnews24.com/2020/11/11/queensberry-confirm-three-positive-coronavirus-tests/" rel="prev">Queensberry confirm three positive coronavirus tests</a></div>
<div class="next"><a href="https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/" rel="next">Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia</a></div>
</div>
<div class="tag-section">
<div><span>Read more articles about: </span><a href="https://www.ringnews24.com/tag/kell-brook/" rel="tag">kell brook</a>, <a href="https://www.ringnews24.com/tag/terence-crawford-boxing-news/" rel="tag">Terence Crawford</a></div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="7447721437"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/"></div><!-- AddThis Share Buttons generic via filter on the_content -->			
									
		</section>
				
		

		
							<footer>
			</footer>
		</article>					
						
						</div>
	
	
</section>

		
								<div id="gk-mainbody-bottom">
					<div id="custom_html-31" class="widget_text box  widget_custom_html"><h3 class="box-title">FITE &#8211; BOXING TV FIXTURES</h3><div class="textwidget custom-html-widget"><a href="https://www.tkqlhce.com/click-5240654-13861698" target="_top" rel="noopener noreferrer">
<img src="https://www.awltovhc.com/image-5240654-13862150" width="728" height="90" alt="" border="0"/></a></div></div><div id="widget_gk_nsp-13" class="box  widget_gk_nsp"><h3 class="box-title">YOU MAY ALSO LIKE&#8230;</h3><div class="gk-nsp mobile_layout horizontal" data-cols="3" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/11/danny-garcia-ready-to-wrest-world-titles-in-errol-spence-jrs-backyard/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Danny-Garcia-widget_gk_nsp-13.jpg" alt="Danny Garcia ready to wrest world titles in Errol Spence Jr's backyard" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/danny-garcia-ready-to-wrest-world-titles-in-errol-spence-jrs-backyard/" title="Danny Garcia ready to wrest world titles in Errol Spence Jr's backyard">Danny Garcia ready to wrest world titles in Errol Spence&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1178455551.jpg.0-widget_gk_nsp-13.jpg" alt="Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/" title="Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia">Errol Spence Jr puts car accident behind him as he&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-widget_gk_nsp-13.jpg" alt="Terence Crawford primed for Kell Brook battle on Saturday night" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" title="Terence Crawford primed for Kell Brook battle on Saturday night">Terence Crawford primed for Kell Brook battle on Saturday night</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/11/andrew-moloney-promises-improved-performance-in-joshua-franco-rematch/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/13894539_web1_Andrew_Moloney_vs_Joshua_Franco_action1-widget_gk_nsp-13.jpg" alt="Andrew Moloney promises improved performance against Joshua Franco in rematch" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/andrew-moloney-promises-improved-performance-in-joshua-franco-rematch/" title="Andrew Moloney promises improved performance against Joshua Franco in rematch">Andrew Moloney promises improved performance against Joshua Franco in rematch</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1-CRAWFORD_POSE_BELTS-widget_gk_nsp-13.jpg" alt="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" title="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”">Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/10/joshua-franco-im-the-better-fighter-overall-than-andrew-moloney-and-thats-just-a-fact/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/franco-moloney-fight-62420-9-widget_gk_nsp-13.jpg" alt="Joshua Franco: “I’m the better fighter overall than Andrew Moloney and that’s just a fact"" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/joshua-franco-im-the-better-fighter-overall-than-andrew-moloney-and-thats-just-a-fact/" title="Joshua Franco: “I’m the better fighter overall than Andrew Moloney and that’s just a fact">Joshua Franco: “I’m the better fighter overall than Andrew Moloney&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/08/kell-brook-ready-to-shock-terence-crawford/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Kell-Brook-1-widget_gk_nsp-13.jpg" alt="Kell Brook ready to shock Terence Crawford" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/08/kell-brook-ready-to-shock-terence-crawford/" title="Kell Brook ready to shock Terence Crawford">Kell Brook ready to shock Terence Crawford</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/08/devin-haney-calls-for-teofimo-lopez-fight-following-victory-over-yuriorkis-gamboa/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/haney-gamboa-ed-mulholland-matchroom-widget_gk_nsp-13.jpg" alt="Devin Haney calls for Teofimo Lopez fight following victory over Yuriorkis Gamboa" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/08/devin-haney-calls-for-teofimo-lopez-fight-following-victory-over-yuriorkis-gamboa/" title="Devin Haney calls for Teofimo Lopez fight following victory over Yuriorkis Gamboa">Devin Haney calls for Teofimo Lopez fight following victory over&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-3"  style="padding: 10px 5px 5px 5px;"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" class="gk-responsive gk-image-link"  style="margin: 10;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3-42-scaled-1-widget_gk_nsp-13.jpg" alt="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt" class="gk-nsp-image gk-responsive" height="125" width="300" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" title="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt">Anthony Joshua insists he wants to fight Tyson Fury for&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-14" class="box  widget_gk_nsp"><h3 class="box-title">TOP STORIES</h3><div class="gk-nsp mobile_layout horizontal" data-cols="2" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/danny-garcia-ready-to-wrest-world-titles-in-errol-spence-jrs-backyard/" title="Danny Garcia ready to wrest world titles in Errol Spence Jr's backyard">Danny Garcia ready to wrest world titles in Errol Spence&hellip;</a></h3><a href="https://www.ringnews24.com/2020/11/11/danny-garcia-ready-to-wrest-world-titles-in-errol-spence-jrs-backyard/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Danny-Garcia-widget_gk_nsp-14.jpg" alt="Danny Garcia ready to wrest world titles in Errol Spence Jr's backyard" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Danny ‘Swift’ Garcia 36-2 (21) is ready to wrest the WBC and IBF welterweight titles from champion Errol ‘The Truth’ Spence Jr 26-0 (21) when they meet at AT&amp;T Stadium in Arlington, Texas on December 5.

The 32-year-old former two-weight world &hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/" title="Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia">Errol Spence Jr puts car accident behind him as he&hellip;</a></h3><a href="https://www.ringnews24.com/2020/11/11/errol-spence-jr-puts-car-accident-behind-him-as-he-zeroes-in-on-danny-garcia/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1178455551.jpg.0-widget_gk_nsp-14.jpg" alt="Errol Spence Jr puts car accident behind him as he zeroes in on Danny Garcia" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">WBC and IBF welterweight champion Errol ‘The Truth’ Spence Jr 26-0 (21) will make his long-awaited return to the ring when he faces Danny ‘Swift’ Garcia 36-2 (21) at AT&amp;T Stadium in Arlington, Texas on December 5.

The 30-year-old Texan southpa&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" title="Terence Crawford primed for Kell Brook battle on Saturday night">Terence Crawford primed for Kell Brook battle on Saturday night</a></h3><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-widget_gk_nsp-14.jpg" alt="Terence Crawford primed for Kell Brook battle on Saturday night" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">WBO welterweight champion Terence ‘Bud’ Crawford 36-0 (27) says he doesn’t know how to rate Kell Brook 39-2 (27) because he has never been in the ring with him.

The 33-year-old southpaw from Omaha, Nebraska will make the fourth defence of his 147-&hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/andrew-moloney-promises-improved-performance-in-joshua-franco-rematch/" title="Andrew Moloney promises improved performance against Joshua Franco in rematch">Andrew Moloney promises improved performance against Joshua Franco in rematch</a></h3><a href="https://www.ringnews24.com/2020/11/11/andrew-moloney-promises-improved-performance-in-joshua-franco-rematch/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/13894539_web1_Andrew_Moloney_vs_Joshua_Franco_action1-widget_gk_nsp-14.jpg" alt="Andrew Moloney promises improved performance against Joshua Franco in rematch" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">Former WBA ‘regular’ super flyweight champion Andrew ‘The Monster’ Moloney 21-1 (14) is promising to deliver a better performance when he meets conqueror Joshua ‘El Profesor’ Franco 17-1-2 (8) at ‘The Bubble’ at the MGM Grand in Las Vegas, Nevada on &hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" title="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”">Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook&hellip;</a></h3><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1-CRAWFORD_POSE_BELTS-widget_gk_nsp-14.jpg" alt="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">WBO welterweight champion Terence ‘Bud’ Crawford 36-0 (27) will face a much tougher test against Kell Brook 39-2 (27) than he did against Amir Khan 34-5 (21), according to manager Bryan ‘BoMac’ McIntyre.

Khan was stopped in six rounds by Crawford &hellip;</p></div><div class="gk-nsp-art gk-nsp-cols-2"  style="padding: 10px 10px 10px 10px;"><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/joshua-franco-im-the-better-fighter-overall-than-andrew-moloney-and-thats-just-a-fact/" title="Joshua Franco: “I’m the better fighter overall than Andrew Moloney and that’s just a fact">Joshua Franco: “I’m the better fighter overall than Andrew Moloney&hellip;</a></h3><a href="https://www.ringnews24.com/2020/11/10/joshua-franco-im-the-better-fighter-overall-than-andrew-moloney-and-thats-just-a-fact/" class="gk-responsive gk-image-link"  style="margin: 2;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/franco-moloney-fight-62420-9-widget_gk_nsp-14.jpg" alt="Joshua Franco: “I’m the better fighter overall than Andrew Moloney and that’s just a fact"" class="gk-nsp-image gk-responsive" height="150" width="300" /></a><p class="gk-nsp-text">WBA ‘regular’ super flyweight champion Joshua ‘El Profesor’ Franco 17-1-2 (8) believes his trilogy of fights against Oscar Negrete 19-2-2 (7) steeled him to become world champion.

During a 10-month period from October 2018 to August 2019 the pair &hellip;</p></div></div></div></div></div></div>				</div>
							</div><!-- end of the #gk-content-wrap -->
			
									<aside id="gk-inset">
				<div id="custom_html-28" class="widget_text box  widget_custom_html"><h3 class="box-title">FOLLOW US</h3><div class="textwidget custom-html-widget"><center><a href="https://twitter.com/Ringnews24" target="_blank" rel="noopener noreferrer"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Twitter.png" width="235" height="500" border=" border=" /></a></center><center><a href="https://www.facebook.com/ringnews24/" target="_blank" rel="noopener noreferrer"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2020/02/Facebook.png" width="235" height="500" border=" border=" /></a></center></div></div><div id="widget_gk_nsp-5" class="box  color all widget_gk_nsp"><h3 class="box-title">TYSON FURY BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3-42-scaled-1-widget_gk_nsp-5.jpg" alt="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" title="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt">Anthony Joshua insists he wants to fight Tyson Fury for&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/05/will-tyson-fury-and-deontay-wilder-ever-fight-again/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/0a573fdb4b29cc898013db4be92f69e0_crop_exact-widget_gk_nsp-5.jpg" alt="Will Tyson Fury and Deontay Wilder ever fight again?" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/05/will-tyson-fury-and-deontay-wilder-ever-fight-again/" title="Will Tyson Fury and Deontay Wilder ever fight again?">Will Tyson Fury and Deontay Wilder ever fight again?</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/04/dereck-chisora-speaks-to-deontay-wilder-about-tyson-fury-claims-offers-to-fight-dillian-whyte/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Dereck-Chisora-v-Artur-Szpilka-widget_gk_nsp-5.jpg" alt="Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims, offers to fight Dillian Whyte" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/04/dereck-chisora-speaks-to-deontay-wilder-about-tyson-fury-claims-offers-to-fight-dillian-whyte/" title="Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims, offers to fight Dillian Whyte">Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims,&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-15" class="box  color all widget_gk_nsp"><h3 class="box-title">ANTHONY JOSHUA BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/3-42-scaled-1-widget_gk_nsp-15.jpg" alt="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/07/anthony-joshua-insists-he-wants-to-fight-tyson-fury-for-the-wbc-belt/" title="Anthony Joshua insists he wants to fight Tyson Fury for the WBC belt">Anthony Joshua insists he wants to fight Tyson Fury for&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/06/anthony-joshua-on-oleksandr-usyk-i-need-to-see-my-competition-in-the-flesh/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Anthony-Joshua-Oleksandr-Uysk-1272309-widget_gk_nsp-15.jpg" alt="Anthony Joshua on Oleksandr Usyk: “I need to see my competition in the flesh”" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/06/anthony-joshua-on-oleksandr-usyk-i-need-to-see-my-competition-in-the-flesh/" title="Anthony Joshua on Oleksandr Usyk: “I need to see my competition in the flesh”">Anthony Joshua on Oleksandr Usyk: “I need to see my&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/05/bob-arum-warns-anthony-joshua-not-to-overlook-kubrat-pulev/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Kubrat-Pulev-widget_gk_nsp-15.jpg" alt="Bob Arum warns Anthony Joshua not to overlook Kubrat Pulev" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/05/bob-arum-warns-anthony-joshua-not-to-overlook-kubrat-pulev/" title="Bob Arum warns Anthony Joshua not to overlook Kubrat Pulev">Bob Arum warns Anthony Joshua not to overlook Kubrat Pulev</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-16" class="box  color all widget_gk_nsp"><h3 class="box-title">MANNY PACQUIAO BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/09/28/manny-pacquiao-short-priced-favourite-to-defeat-conor-mcgregor-in-boxing-bout/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Manny-Pacquiao-widget_gk_nsp-16.jpg" alt="Manny Pacquiao short-priced favourite to defeat Conor McGregor in boxing bout" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/09/28/manny-pacquiao-short-priced-favourite-to-defeat-conor-mcgregor-in-boxing-bout/" title="Manny Pacquiao short-priced favourite to defeat Conor McGregor in boxing bout">Manny Pacquiao short-priced favourite to defeat Conor McGregor in boxing&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/09/27/is-manny-pacquiao-vs-conor-mcgregor-really-happening-early-odds-favor-manny/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/manny_pacquiao-widget_gk_nsp-16.jpg" alt="Is Manny Pacquiao vs Conor McGregor really happening? Early odds favor Manny" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/09/27/is-manny-pacquiao-vs-conor-mcgregor-really-happening-early-odds-favor-manny/" title="Is Manny Pacquiao vs Conor McGregor really happening? Early odds favor Manny">Is Manny Pacquiao vs Conor McGregor really happening? Early odds&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/09/19/keith-thurman-admits-he-suffered-depression-following-manny-pacquiao-loss/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Pacquiao-Thurman-2-widget_gk_nsp-16.jpg" alt="Keith Thurman admits he suffered depression following Manny Pacquiao loss" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/09/19/keith-thurman-admits-he-suffered-depression-following-manny-pacquiao-loss/" title="Keith Thurman admits he suffered depression following Manny Pacquiao loss">Keith Thurman admits he suffered depression following Manny Pacquiao loss</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-17" class="box  color all widget_gk_nsp"><h3 class="box-title">TERENCE CRAWFORD BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/WBO_welterweight_champion_Terence_Crawford_photo_by_Mikey_Williams_resMain-widget_gk_nsp-17.jpg" alt="Terence Crawford primed for Kell Brook battle on Saturday night" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" title="Terence Crawford primed for Kell Brook battle on Saturday night">Terence Crawford primed for Kell Brook battle on Saturday night</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1-CRAWFORD_POSE_BELTS-widget_gk_nsp-17.jpg" alt="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/terence-crawfords-manager-labels-amir-khan-soft-says-kell-brook-is-rough/" title="Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook is “rough”">Terence Crawford’s manager labels Amir Khan “soft”, says Kell Brook&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/10/big-fight-prediction-terence-crawford-v-kell-brook/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/CrawfordBrook_sm-header-widget_gk_nsp-17.jpg" alt="Big Fight Prediction - Terence Crawford v Kell Brook" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/10/big-fight-prediction-terence-crawford-v-kell-brook/" title="Big Fight Prediction - Terence Crawford v Kell Brook">Big Fight Prediction - Terence Crawford v Kell Brook</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-18" class="box  color all widget_gk_nsp"><h3 class="box-title">DEONTAY WILDER BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/04/dereck-chisora-speaks-to-deontay-wilder-about-tyson-fury-claims-offers-to-fight-dillian-whyte/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Dereck-Chisora-v-Artur-Szpilka-widget_gk_nsp-18.jpg" alt="Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims, offers to fight Dillian Whyte" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/04/dereck-chisora-speaks-to-deontay-wilder-about-tyson-fury-claims-offers-to-fight-dillian-whyte/" title="Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims, offers to fight Dillian Whyte">Dereck Chisora speaks to Deontay Wilder about Tyson Fury claims,&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/02/is-deontay-wilder-vs-andy-ruiz-a-possibility/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/f331e2f7b95be18e79f207865baeed1d-widget_gk_nsp-18.jpg" alt="Is Deontay Wilder vs. Andy Ruiz a possibility?" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/02/is-deontay-wilder-vs-andy-ruiz-a-possibility/" title="Is Deontay Wilder vs. Andy Ruiz a possibility?">Is Deontay Wilder vs. Andy Ruiz a possibility?</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/21/eddie-hearn-claims-deontay-wilder-has-bottled-it-after-tyson-fury-fight-cancelled/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/690-widget_gk_nsp-18.jpg" alt="Eddie Hearn claims Deontay Wilder has bottled it after Tyson Fury fight cancelled" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/21/eddie-hearn-claims-deontay-wilder-has-bottled-it-after-tyson-fury-fight-cancelled/" title="Eddie Hearn claims Deontay Wilder has bottled it after Tyson Fury fight cancelled">Eddie Hearn claims Deontay Wilder has bottled it after Tyson&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-19" class="box  color all widget_gk_nsp"><h3 class="box-title">CANELO ALVAREZ BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/11/07/canelo-alvarez-released-from-contract-with-golden-boy-and-dazn/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Canelo-Alvarez-Oscar-de-La-Hoya-widget_gk_nsp-19.jpg" alt="Canelo Alvarez released from contract with Golden Boy and DAZN" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/11/07/canelo-alvarez-released-from-contract-with-golden-boy-and-dazn/" title="Canelo Alvarez released from contract with Golden Boy and DAZN">Canelo Alvarez released from contract with Golden Boy and DAZN</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/19/errol-spence-jr-prepared-to-jump-up-two-weight-classes-to-face-canelo-alvarez/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1178455551.jpg.0-widget_gk_nsp-19.jpg" alt="Errol Spence Jr prepared to jump up two weight classes to face Canelo Alvarez" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/19/errol-spence-jr-prepared-to-jump-up-two-weight-classes-to-face-canelo-alvarez/" title="Errol Spence Jr prepared to jump up two weight classes to face Canelo Alvarez">Errol Spence Jr prepared to jump up two weight classes&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/06/is-this-the-last-weve-seen-of-canelo-alvarez-on-dazn/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/180916002916-02-canelo-alvarez-gennady-golovkin-fight-0915-exlarge-169-widget_gk_nsp-19.jpg" alt="Is this the last we’ve seen of Canelo Alvarez on DAZN?" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/06/is-this-the-last-weve-seen-of-canelo-alvarez-on-dazn/" title="Is this the last we’ve seen of Canelo Alvarez on DAZN?">Is this the last we’ve seen of Canelo Alvarez on&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-20" class="box  color all widget_gk_nsp"><h3 class="box-title">FLOYD MAYWEATHER BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/28/the-importance-of-floyd-mayweather-in-gervonta-davis-corner/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1-Z7IGrS_9rxldBTEqxz7hPA-widget_gk_nsp-20.jpeg" alt="The Importance of Floyd Mayweather in Gervonta Davis’ corner" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/28/the-importance-of-floyd-mayweather-in-gervonta-davis-corner/" title="The Importance of Floyd Mayweather in Gervonta Davis’ corner">The Importance of Floyd Mayweather in Gervonta Davis’ corner</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/07/gervonta-davis-promises-early-knockout-of-leo-santa-cruz/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/gervonta-davis-widget_gk_nsp-20.jpg" alt="Gervonta Davis promises early knockout of Leo Santa Cruz" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/07/gervonta-davis-promises-early-knockout-of-leo-santa-cruz/" title="Gervonta Davis promises early knockout of Leo Santa Cruz">Gervonta Davis promises early knockout of Leo Santa Cruz</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/03/tank-davis-vs-leo-santa-cruz-moved-to-oct-31-to-avoid-ufc-clash-and-allow-live-crowd/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/1-Z7IGrS_9rxldBTEqxz7hPA-widget_gk_nsp-20.jpeg" alt="Tank Davis vs Leo Santa Cruz moved to Oct 31 to avoid UFC clash and allow live crowd" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/03/tank-davis-vs-leo-santa-cruz-moved-to-oct-31-to-avoid-ufc-clash-and-allow-live-crowd/" title="Tank Davis vs Leo Santa Cruz moved to Oct 31 to avoid UFC clash and allow live crowd">Tank Davis vs Leo Santa Cruz moved to Oct 31&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-23" class="box  color all widget_gk_nsp"><h3 class="box-title">GENNADY GOLOVKIN BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/02/how-would-jermall-charlo-do-vs-gennady-golovkin/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Gennady-Golovkin-widget_gk_nsp-23.jpg" alt="How would Jermall Charlo do vs. Gennady Golovkin?" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/02/how-would-jermall-charlo-do-vs-gennady-golovkin/" title="How would Jermall Charlo do vs. Gennady Golovkin?">How would Jermall Charlo do vs. Gennady Golovkin?</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/08/07/manny-pacquiao-pours-cold-water-on-gennady-golovkin-plan/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/Manny-Pacquiao-Buboy-Fernandez-Freddie-Roach-Justin-Fortune-widget_gk_nsp-23.jpg" alt="Manny Pacquiao pours cold water on Gennady Golovkin plan" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/08/07/manny-pacquiao-pours-cold-water-on-gennady-golovkin-plan/" title="Manny Pacquiao pours cold water on Gennady Golovkin plan">Manny Pacquiao pours cold water on Gennady Golovkin plan</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/05/11/chris-eubank-jr-missed-out-on-gennady-golovkin-fight-over-photo/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/chris-eubank-jr-widget_gk_nsp-23.jpg" alt="Chris Eubank Jr missed out on Gennady Golovkin fight over photo" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/05/11/chris-eubank-jr-missed-out-on-gennady-golovkin-fight-over-photo/" title="Chris Eubank Jr missed out on Gennady Golovkin fight over photo">Chris Eubank Jr missed out on Gennady Golovkin fight over&hellip;</a></h3></div></div></div></div></div></div><div id="widget_gk_nsp-24" class="box  color all widget_gk_nsp"><h3 class="box-title">VASILIY LOMACHENKO BOXING NEWS</h3><div class="gk-nsp mobile_layout vertical" data-cols="1" data-rows="3" data-links="" data-autoanim="off" data-autoanimint="5000" data-autoanimhover="on"><div class="gk-nsp-arts"><div class="gk-nsp-arts-scroll gk-nsp-pages-1"><div class="gk-nsp-arts-page gk-nsp-cols-1"><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/21/vasiliy-lomachenko-undergoes-shoulder-surgery-following-loss-to-teofimo-lopez/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/skysports-teofimo-lopez-vasiliy-lomachenko_5142017-widget_gk_nsp-24.jpg" alt="Vasiliy Lomachenko undergoes shoulder surgery following loss to Teofimo Lopez" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/21/vasiliy-lomachenko-undergoes-shoulder-surgery-following-loss-to-teofimo-lopez/" title="Vasiliy Lomachenko undergoes shoulder surgery following loss to Teofimo Lopez">Vasiliy Lomachenko undergoes shoulder surgery following loss to Teofimo Lopez</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/18/teofimo-lopez-complete-the-takeover-with-unanimous-decision-win-over-vasiliy-lomachenko/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/lopez-lomachenko-action-widget_gk_nsp-24.jpg" alt="Teofimo Lopez completes ‘The Takeover’ with unanimous decision win over Vasiliy Lomachenko" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/18/teofimo-lopez-complete-the-takeover-with-unanimous-decision-win-over-vasiliy-lomachenko/" title="Teofimo Lopez completes ‘The Takeover’ with unanimous decision win over Vasiliy Lomachenko">Teofimo Lopez completes ‘The Takeover’ with unanimous decision win over&hellip;</a></h3></div><div class="gk-nsp-art gk-nsp-cols-1"  style="padding: 20px 0 0 0;"><a href="https://www.ringnews24.com/2020/10/15/teofimo-lopez-promises-a-takeover-while-vasiliy-lomachenko-plays-it-cool/" class="gk-responsive gk-image-link"  style="margin: 0 0 20px 0;"><img src="https://www.ringnews24.com/wp-content/themes/News/gavern/cache_nsp/vasiliy-lomachenko-3_2020_10_15_043937-widget_gk_nsp-24.jpg" alt="Teofimo Lopez promises a "takeover" while Vasiliy Lomachenko plays it cool" class="gk-nsp-image gk-responsive" height="128" width="230" /></a><h3 class="gk-nsp-header"><a href="https://www.ringnews24.com/2020/10/15/teofimo-lopez-promises-a-takeover-while-vasiliy-lomachenko-plays-it-cool/" title="Teofimo Lopez promises a takeover while Vasiliy Lomachenko plays it cool">Teofimo Lopez promises a "takeover" while Vasiliy Lomachenko plays it&hellip;</a></h3></div></div></div></div></div></div>			</aside>
								</section><!-- end of the mainbody section -->
	
						<aside id="gk-sidebar">
			<div id="text-11" class="box   onlyDesktop widget_text"><h3 class="box-title">Google ads</h3>			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center>
</div>
		</div><div id="custom_html-30" class="widget_text box  widget_custom_html"><h3 class="box-title">FITE &#8211; BOXING PPV SCHEDULE</h3><div class="textwidget custom-html-widget"><a href="https://www.anrdoezrs.net/click-5240654-13862163" target="_top" rel="noopener noreferrer">
<img src="https://www.ftjcfx.com/image-5240654-13862163" width="235" height="235" alt="" border="0"/></a></div></div><div id="text-2" class="box   onlyDesktop widget_text">			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="text-20" class="box   onlyDesktop widget_text"><h3 class="box-title">World Boxing Forum</h3>			<div class="textwidget"><center><a href=" http://www.koboxingforum.com/forumdisplay.php?f=18"><img class="aligncenter" style="border: 0;" src="https://www.ringnews24.com/wp-content/uploads/2018/04/boxingforumrn24ad2.png" width="235" height="500" border=" border=" /></a></center></div>
		</div><div id="text-9" class="box   onlyDesktop widget_text"><h3 class="box-title">Google Ads</h3>			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Display Ad - Sidebar 444 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-5502369698975283"
     data-ad-slot="9754526477"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div><div id="custom_html-29" class="widget_text box  widget_custom_html"><h3 class="box-title">BOXING TICKETS</h3><div class="textwidget custom-html-widget"><a href="http://www.awin1.com/cread.php?awinmid=2448&amp;awinaffid=141682&amp;clickref=&amp;p=https%3A%2F%2Fwww.viagogo.com%2FSports-Tickets%2FBoxing" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ecffc9fef160e7a922085f85843c8328_400x400.jpg" alt="" width="300" height="600" /></a>

<a href="https://www.awin1.com/cread.php?s=555835&amp;v=4307&amp;q=139037&amp;r=141682" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/Stubhub-matchroom.png" alt="" width="300" height="600" /></a>

<a href="http://www.awin1.com/cread.php?awinmid=2448&amp;awinaffid=141682&amp;clickref=&amp;p=https%3A%2F%2Fwww.viagogo.com%2FSports-Tickets%2FBoxing" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/Stubhub.png" alt="" width="300" height="600" /></a>

<a href="http://rover.ebay.com/rover/1/711-53200-19255-0/1?ff3=4&amp;pub=5575023557&amp;toolid=10001&amp;campid=5338169919&amp;customid=&amp;mpre=https%3A%2F%2Fwww.ebay.com%2Fsch%2Fi.html%3F_from%3DR40%26_trksid%3Dp2487218.m570.l1313.TR7.TRC2.A0.H0.Xboxing%2Btickets.TRS0%26_nkw%3Dboxing%2Btickets%26_sacat%3D173633" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ebay.com_.jpg" alt="" width="300" height="600" /></a>

<a href="http://rover.ebay.com/rover/1/710-53481-19255-0/1?ff3=4&amp;pub=5575023557&amp;toolid=10001&amp;campid=5338169932&amp;customid=&amp;mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fsch%2Fi.html%3F_from%3DR40%26_trksid%3Dp2487218.m570.l1313.TR12.TRC2.A0.H0.Xboxing%2Btickets.TRS0%26_nkw%3Dboxing%2Btickets%26_sacat%3D170590" target="_blank" rel="nofollow noopener noreferrer"><img class="alignnone size-full wp-image-64985" src="https://www.ringnews24.com/wp-content/uploads/2017/08/ebay.co_.uk_.jpg" alt="" width="300" height="600" /></a></div></div>		</aside>
						<!--[if IE 8]>
		<div class="ie8clear"></div>
		<![endif]-->
	</div><!-- end of the #gk-mainbody-columns -->
</div><!-- end of the .gk-page-wrap section -->	


<div id="gk-bottom2" class="gk-page widget-area">
	<div id="text-12" class="box  widget_text col6 nth1 last4"><h3 class="box-title">Welcome</h3>			<div class="textwidget"><p>Welcome to Ringnews24; read the latest boxing news from around the world.</p>
<p>The site is run by boxing fans James Tonks and Lee Daley. </p>
<p>If you have any questions or suggestions, feel free to<a href="mailto:ringnews24@ringnews24.com" rel="nofollow">Email Us</a></p>

</div>
		</div><div id="text-13" class="box  widget_text col6 nth2 last4"><h3 class="box-title">Write for Ringnews24</h3>			<div class="textwidget"><ul>
<li><a href="https://www.ringnews24.com/2013/12/15/submit-your-boxing-article/" >Become a boxing writer on Ringnews24</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/writers-guide/#.VbJA6_mHwn8" >How to submit an article</a></li>

<li><a href="https://www.ringnews24.com/2015/07/24/qa-ringnews24/" >Writers Q/A</a></li>

<li><a href="https://www.ringnews24.com/2013/05/25/writers-articles-2/#.VbJJwvmHwn8" >Author List</a></li>

<li><a href="https://www.ringnews24.com/2015/09/01/writers-style-guide/#.Ve6ZTZeHwwI">Writers Style Guide</a><li>

<li><a href="https://www.ringnews24.com/2016/01/05/how-to-add-a-image/#.VouxVlJyNf0">How to add a photo to your article
</a><li>

</ul></div>
		</div><div id="text-14" class="box   onlyDesktop widget_text col6 nth3 last4"><h3 class="box-title">KO BOXING FORUM</h3>			<div class="textwidget"><ul>
	<li><a href="http://www.koboxingforum.com/forums/18-World-Boxing-Forum" target="_blank>World Boxing News</a></li>

	<li><a href="http://www.koboxingforum.com/forums/25-Boxing-History-Forum" target="_blank" rel="noopener noreferrer">Boxing History Forum</a></li>

<li><a href="http://www.koboxingforum.com/forums/27-Boxing-Training-and-Nutrition" target="_blank" rel="noopener noreferrer">Boxing Training and Nutrition</a></li>

<li><a href="http://www.koboxingforum.com/forums/20-Prediction-League" rel="nofollow noopener noreferrer" target="_blank">Prediction League</a></li>

<li><a href="http://www.koboxingforum.com/forums/49-Buy-and-Sell-Boxing-Goods-on-eBay" target="_blank" rel="noopener noreferrer">Sell your eBay items</a></li>

<li><a href="http://www.koboxingforum.com/forums/17-Chatterbox" rel="nofollow noopener noreferrer" target="_blank">Chatterbox</a></li>

<li><a href="http://www.koboxingforum.com/register.php" target="_blank" rel="noopener noreferrer">Register Here</a></li>

</ul></div>
		</div><div id="text-15" class="box   onlyDesktop widget_text col6 nth4 last4"><h3 class="box-title">CONNECT WITH US</h3>			<div class="textwidget"><ul>

<li><a href="https://www.ringnews24.com/boxing-social-media/" >Social Media Wall</a></li>

<li><a href="https://twitter.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Twitter</a></li>

<li><a href="https://www.facebook.com/ringnews24" rel="nofollow noopener noreferrer" target="_blank">Facebook</a></li>

<li><a href="https://www.pinterest.com/ringnews24/boxing/" rel="nofollow noopener noreferrer" target="_blank">Pinterest</a></li>

<li><a href="https://www.ringnews24.com/feed/" target="_blank" rel="noopener noreferrer">RSS</a></li>

<li><a href="https://www.ringnews24.com/2018/02/20/about-us-2/" >About Us</a></li>

<li><a href="https://www.ringnews24.com/2013/05/26/contact-us/" >Contact Us</a></li>

</ul>
</div>
		</div>	<!--[if IE 8]>
	<div class="ie8clear"></div>
	<![endif]-->
</div>

	<footer id="gk-footer" class="gk-page">			
				
		<div class="gk-copyrights">
			© Ringnews24		</div>
		
		
				
				
	</footer>
	
	
<div id="gk-popup-login">	
	<div class="gk-popup-wrap">
				    
			
		<form name="loginform" id="loginform" action="https://www.ringnews24.com/boxingauthor/" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
				<input type="hidden" name="redirect_to" value="https://www.ringnews24.com/2020/11/11/terence-crawford-primed-for-kell-brook-battle-on-saturday-night/" />
			</p>
			
		</form>		
			</div>
</div>

<div id="gk-popup-overlay"></div>
	
		
		
		
	<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"ringnews24"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-54900234-1","data_ga_social":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-932a1e8a51a6107c59319588e16a24c5","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55a3b52069ede608" async="async"></script><script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.scripts.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-scripts-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.typography.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-shortcodes-typography-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.elements.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-shortcodes-elements-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/shortcodes.template.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-shortcodes-template-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/thickbox/thickbox.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-thickbox-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringnews24.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3' id='contact-form-7-js'></script>
<script type='text/javascript' id='rss-retriever-ajax-js-extra'>
/* <![CDATA[ */
var rss_retriever = {"ajax_url":"https:\/\/www.ringnews24.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/plugins/wp-rss-retriever/inc/js/rss-retriever-ajax.js?ver=1.6.5' id='rss-retriever-ajax-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/nsp.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gk-nsp-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/widgets/tabs.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gk-tabs-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-includes/js/wp-embed.min.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.ringnews24.com/wp-content/themes/News/js/gk.menu.js?ver=4478bc98c011648881d6f6881ca2a7b5' id='gavern-menu-js'></script>
	
	
					<script type="text/javascript">
			  var _gaq = _gaq || [];
			  _gaq.push(['_setAccount', 'UA-54900234-2']);
			  _gaq.push(['_trackPageview']);
			
			  (function() {
			    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			  })();
			</script>

		</body>
</html>

<!-- Dynamic page generated in 0.897 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-11-12 05:31:57 -->

<!-- Compression = gzip -->